How to disable the app menu functionality ("global menu") in LibreOffice, Ubuntu 12.10?


The gtk-desktop integration activates the unitymenu if unity is available. This can be prevented by uninstalling libreoffice-gtk, which also removes all themeing and results in a very ugly LibreOffice without unity integration.

  • 2
    Bjoern Michaelsen -- That worked. As you indicated it is ugly but at least I can use LibreOffice now. This upgrade from 12.04 to 12.10 has some terribly nasty side effects even beyond this one. For instance alt-Tab not identifying some applications which were minimized and therefore unrecoverable. Bad show, ubuntu, very bad show. – user101994 Oct 29 '12 at 19:06
  • upgrading/updating often scares me, the global menu is so annoying and troublesome..; this answer fix for me on 12.10, it also enforces removal of libreoffice-gnome, but til now I see no problems on that, and the "ugly interface" is not that ugly... and most importantly it works fine now what is MUCH better than looking pretty :) – Aquarius Power Jan 12 '14 at 22:15
  • This fix also works in Ubuntu 15.04 – Ian D. Allen May 3 '15 at 21:19

Let me quote an answer from How do I enable or disable the global application menu?. This is how you disable the app menu on a per application basis :

To disable appmenu support on a per application basis, set the UBUNTU_MENUPROXY variable to null, with:


the env keyword is useful if your trying to launch the application with the ALT-F2 shortcut.

You'll find more details on https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationMenu#Troubleshooting.

  • 3
    I don't believe this works for Libreoffice, because if I'm not wrong, global menus for certain applications (like Libreoffice and Firefox) are implemented in an application-specific manner. – ztangent Oct 28 '12 at 3:31

As Flimm already stated, removing lo-menubar won't remove LibreOffice's Global Menu.

To remove LibreOffice's Global Menu, you need to remove this package:

sudo apt-get remove indicator-appmenu
  • This did not work in 13.04... The menu is still in the top bar... – Alexis Wilke Sep 26 '13 at 20:20

If you want to remove the "global menu" just for libre office this could work:

sudo apt-get remove lo-menubar

If you want to remove the "global menu" from ALL applications you should do the following on the terminal:

sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt

If you want to put it back then use this on the terminal:

sudo apt-get install appmenu-gtk3 appmenu-gtk appmenu-qt

I hope this could help you. Good luck!

  • lo-menubar in Ubuntu 12.10 is just a dummy package, so removing it won't have any effect. – Flimm Jan 21 '13 at 20:52
  • These worked in 12.04, but with 12.10 and 13.04, the LibreOffice menu is integrated in libreoffice-gtk so removing those things does not help with LibreOffice. – Alexis Wilke Sep 26 '13 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.