2

I have a micro ubuntu instance on ec2. I have done a passwd to set it to simple password. I have installed vsftpd on the ec2 instance. And imported the ec2 pem file via FileZilla-Settings-SFTP, and configured vsftpd.conf with following

listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
secure_chroot_dir=/var/run/vsftpd/empty
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/private/vsftpd.pem
local_root=/home/ubuntu
pasv_enable=YES
pasv_max_port=12100
pasv_min_port=12000
port_enable=YES

I am using username ubuntu, password that_i_set, port 21. I get the following error

Error:  Critical error
Error:  Could not connect to server
1
  • did you set up your security group in ec2 manager to allow ports 20, 21, 12100 and 12000? – user103193 Oct 30 '12 at 16:45
0

Please set the security group in EC2 and allow the port 22. and please use port 22 instead of 21.

Also you can view the security group setting on following URL: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/using-network-security.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.