I am running 10.10 (all current updates have been installed) and I'm unable to sync any files to U1. U1 shows my computer as being added to my account and I bought enough space to hold all the files I want backed up, but for some reason it still doesn't sync. I have marked the files to be synced and even checked the devices tab in the U1 preferences; it shows my computer as being part of my account but the connect button is inoperable and restart doesn't produce any effect when clicked. When using u1sdtool I sometimes get an ugly DBus error, and other times get State: READY.

I have tried the line commands posted by bisi, they seem to be the same commands as those given in a similar question. I have also ran U1sdtool --status check and heres what came up

  State: READY
    connection: Not User With Network
    description: ready to connect
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING_ON_BOTH

I'm not very techno savvy so step by step and/or lay mens terms are greatly appreciated, Thank you


Up to and including 10.10 the startup of syncdaemon, the bit of ubuntuone-client in charge of synchronizing your files, could take quite some time: tens of minutes on a slow disc with a large number (tens of thousands) of files kept in sync by Ubuntu One. If you try using u1sdtool during that time, you can easily trigger the above DBus error. It's ugly, and we're working to make it go away for 11.04, but it's also innocuous. You could read it as a “I'm busy, please try again in a few minutes”.

Now, there's another issue in 10.10 that we've fixed and you should have actually gotten the fix in your regular updates, and that is that it sometimes doesn't connect automatically. A state of READY means that syncdaemon is ready to go as soon as you tell it to connect.

ubuntuone-preferences (System › Preferences › Ubuntu One) should be offering you a “Connect” button in that state. If it's not, please file a bug; meanwhile, you can enter u1sdtool -c on the commandline to manually ask it to connect.


From what I have gathered thus far, it takes a while for U1 to actually connect and start syncing. This depends on the one hand on the amount of folders/files that you've chosen to synchronize (I think the filesize plays less of a role), and on the other side, is a U1-related issue that they intend to fix in the release of the next version of Ubuntu (Natty Narwhal, which I wouldn't recommend installing of you say you're not techsavy ;), I know I didn't (yet)).

I'd recommend however to install ubuntuone-indicator and magicada. Also, in Terminal you may want to try the following commands:

u1sdtool -q; u1sdtool --start; u1sdtool -c

This has done it a number of times for me to start connecting (after an hour or so maybe), but today for example, that didn't do it. Try again, and don't forget to give it a chance to sort it self out by waiting a little before pressing restart and the such again ;)

EDIT: I have noticed that whenever ubuntuone-indicator shows "Ready to connect" rather than starting or the like, it actually connects as soon as you click on connect. Not sure how to get there, but the last time I tried to get it to work was about 12 hours ago, and now just back home, it started syncing right away... I did do more of the Restart in Ubuntu One Preferences this morning, maybe that does it, you just need to wait?...

Good luck!


  • Thanks for the reply, I tryed the commands in Terminal with no luck, nothing syncs or even tries to sync. Time doesn't seem matter, I have given it all day and still no sync. – wrenchman76 Jan 10 '11 at 13:51
  • Update: I retried the line commands you posted and about the 40th time I received an error message as follows - – wrenchman76 Jan 10 '11 at 18:02
  • Oops, an error ocurred: Traceback (most recent call last): Failure: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken" Did I break it, not the connection but my ability to use U1? Am I ---- out of luck? – wrenchman76 Jan 10 '11 at 18:08
  • Hey Wrenchman! I really am no expert, but rest assured, I get that message as well every now and then, and at some point, I get it to work ;). It's still sort of a lucky game, to see which will eventually connect you... every now and then, after trying several steps, I just try one more (just now u1sdtool -c), and I hear my harddrive spinning, and I know it'll kick off in a moment :)... I am sorry, this is all I know for this, an expert will need to step in...for all I know, it is just taking its time to connect at all, no matter what commands we use?... for Natty, it'll be better! ;) – bisi Jan 10 '11 at 23:44
  • Correction. It didn't do it for me... One more feat that seems to have worked in the past was to "restart" in Ubuntu One preferences? Trying that now. Positive thing to keep you going: been fiddling with this as a noob for about 2 weeks now, and I've managed to sync 40GB. It can work ;) Good luck! – bisi Jan 10 '11 at 23:49

If you are connected to the Internet behind a proxy, then it is not possible yet to use Ubuntu One. Try connecting to the web without a proxy.

  • I wouldn't know but if I had to guess I'd say no I'm not, but if I am how would I find out and even better how do I change it so that I'm not? – wrenchman76 Jan 10 '11 at 13:53
  • @wrenchman if you were behind a proxy, you'd probably know (as you have to set it up). Just in case, check System > Preferences > Network Proxy – Chipaca Jan 10 '11 at 14:54
  • No sir, I checked and no proxy. – wrenchman76 Jan 10 '11 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy