I'm on Ubuntu 12.04 with Thunderbird 16.0.1 and Kernel 3.6.0-030600rc4-generic. I used Thunderbird for quite a while and never had any problems with it. But now it seems to fill up my disk space very fast:

watch -n 1 df -h .

so Ubuntu started giving out warnings. First I removed some files but not much later it had filled up around 600 MB. It eats around 50 MB/min while I just download 10 emails or so via IMAP. This behaviour is new and seems to be some kind of bug. I don't want to delete my old mails, so what else could I do?

  • Hello Kris, welcome on Ask Ubuntu ! Do you know how much space your emails take on the server ? In Gmail, for instance, it is easy to know since it is simply written at the bottom of the web interface page. – Agmenor Oct 25 '12 at 15:47
  • A new version (16.0.2) has been released today and it seems that it fixes the problem – Jonathan Pasquier Oct 30 '12 at 8:47

Your issue is certainly related to a regression introduced in TB16 and which impact some IMAP servers (like dovecot).

Bug 803843 - IMAP mailfiles keep growing to gigabyte size

|improve this answer|||||
  • OMG I had the same issue, 143GB of space used! Problem was Thunderbird 16.0.1, upgrading to 16.0.2 and repairing the folders seems to have freed up my space, will watch to see if the issue still occurs – Phill Pafford Nov 5 '12 at 13:36

Have you tried this : http://kb.mozillazine.org/Compacting_folders

Because this article is for old Thunderbird versions, you will find the option here: Edit / Preferences / Advanced / Network & Disk Space. Also it is turned ON by default with this setting: Compact all folders when it will save over 20 MB in total.

If not give it a try. What I think that you are victim is that thunderbird may have a little bug that doesn't clean well his folder.

IMAP is quite complex and what is happening is that your e-mails are on the server but downloaded to your mail client.

If it's on his default settings then thunderbirds must delete what has been deleted from the server. that part may have some trouble.

Best regards,

|improve this answer|||||

I had exactly the same problem. I made some space in my home and thunderbird ate it all. Compacting was not possible ("No space left on device" it kept saying). My "ImapMail" folder had more than 20GB!

I found out that in one of my email account imap folders were files INBOX (7.3GB) and Sent (8.6GB). I closed Thunderbird and then moved those two files to my external hard drive (as backup). After openning Thunderbird again it created new files, which had been moved, and now they have only few kilobytes. I haven't lost any emails and everything works as before.

|improve this answer|||||

The fix that worked for me for IMAP related problems:

Backup your profile folder using something like MozBackup. Start Thunderbird. Move all of the messages in the Inbox to other folders/child folders. You can select all of the messages using Control-A. If you have problems moving all of the messages, do it in multiple steps, where you select only a few messages each time. Verify that all of the messages have been moved. Exit Thunderbird and Go to your 'Home' folder hit ctrl+H to un-hide the hidden files, go to path '/home/user_name/.thunderbird/4kh5v6hf.default/ImapMail'. Now,delete BOTH the "inbox." and "inbox.msf" files for that account. Leave "Inbox.sbd" alone. You can find where the Inbox folder is stored by looking at Tools -> Account Settings -> Server Settings -> Local Directory, or Tools -> Account Settings -> Local Folders -> Local Directory if you are using a Global Inbox. Its at the bottom of that pane, next to a Browse button. Start Thunderbird. It will automatically create a new Inbox folder.

While it's possible to move the messages back to the (new) Inbox, it's recommended you don't do that.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.