5

I bought a HP ENVY 6-1060ss, it has 2 front speakers and a built-in subwoofer. I can't get the subwoofer to work. I have looked around for answers, and found quite a lot, but still, nothing works.

I have already tried (from already answered questions):

  • Edited /etc/pulse/daemon.conf setting enable-lfe-remixing: from no to yes, and the channels number from 2 to 3.

  • Edited /etc/modprobe.d/alsa-base.conf, adding options snd-hda-intel model=hp-zephyr and options snd-hda-intel model=ref.

Any other thoughts?

0

This worked for me on my HP Envy w/ Beats Audio: http://forums.gentoo.org/viewtopic-t-859769.html Ubuntu now recognizes and uses the center-channel (so-called) subwoofer.

-Todd w.todd.land@gmail.com

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Peachy Nov 19 '12 at 13:33
  • Could you clarify the exact steps you took to get this working? I've got exactly the same problem at the moment and would love to get the subwoofer working. – Jeremy Jan 5 '13 at 14:20
0

Did you also try?

 sudo gedit /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf

-- add the lines below:

[Mapping analog-surround-21]
device-strings = surround40:%f
channel-map = front-left,front-right,lfe,lfe
paths-output = analog-output analog-output-speaker
priority = 7
direction = output

Reboot. You should have an extra mode in your "hardware" menu of the "sound" menu named "Analog surround 2.1"

can you do an lspci and tell me which sound card is your PC using?

  • Thanks for your answer. I did what you told me, but didn't get any new hardware profiles... still, it bugs me that the ones named in the extra-hdmi.conf aren't exactly the ones shown under hardware profiles! lspci returned: 00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04) 01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01) – user100787 Nov 15 '12 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.