This question already has an answer here:

When I run this command:

apt-get install git-core

It shows:

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

marked as duplicate by Oli Mar 10 '14 at 17:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • plzz help me whtat to do – Manoj Chauhan Oct 25 '12 at 12:01
  • have you tried running with sudo as in sudo apt-get install git-core? – Peachy Oct 25 '12 at 18:05

Prefix the command with sudo. This gives you Administrative permissions for one command (runs it as the root user). You will be prompted for your user password.


sudo apt-get install git

More information on sudo here

Note: You may also temporarily log in as root by typing sudo su

Install via the software center


Since the OP posted new information with a different error:

Only one instance of the package manager/updater can be running at one time. Make sure you have no other terminals trying to install software, or that your Software Updater isn't trying to install updates. Best way to make sure of this if you're not sure is to restart, then run the command in the terminal before you do anything else.


git-core is now an obsolete package in the PPA. The package has been renamed to simply git. I have updated my answer and link accordingly.

  • nothing happening... – Manoj Chauhan Oct 25 '12 at 12:48
  • What do you mean by "Nothing Happening"? Are you getting the same error? Are you getting something else? If so, edit your question and post the new results. – Kyle Macey Oct 25 '12 at 13:05
  • manu@manu-G31M-ES2L:~$ sudo apt-get install git-core [sudo] password for manu: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? – Manoj Chauhan Oct 25 '12 at 17:34
  • @ManojChauhan Check my edit – Kyle Macey Oct 25 '12 at 18:01
  • thanxx its working .. – Manoj Chauhan Oct 26 '12 at 11:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.