After upgrading to Quantal yesterday I installed the new ATI Catalyst drivers, the 12.10 version, for my ATI Radeon HD 7850 card. Upon logging into Ubuntu I am presented with no Unity. I can access terminal with Ctrl + Alt + T.

I tried uninstalling the driver, but that did not fix Compiz.

Does anyone know how I can fix Compiz? Any info on getting drivers working would be good too.

Edit: I solved this problem by first uninstalling the proprietary driver through the terminal, which I believe is in /usr/share/ati/amd-uninstall.sh. Then I rebooted and installed the open source driver, radeon, and rebooted again. It's slower than the proprietary drivers but it works.

  • 1
    fglrx is the proprietary driver – OregonTrail Feb 13 '13 at 14:00
  • That was a typo. I later fixed it with the accepted solution. Thanks for pointing out my error. – Clintonio Feb 17 '13 at 10:45

Hi I have the answere for all of you, the problem is 12.10 doesn't include the kernel headers for some reason. so when installing drivers run sudo apt-get install linux-headers-$(uname -r) you can do this before or after it doesn't mater. Once thats done reboot your system and enjoy!

  • Thank you! This solved my problem (broken Compiz with fglrx). After a reboot, I had to add nomodeset to my linux boot line on grub or else I would be stuck at the logo (purple) screen. – OregonTrail Feb 13 '13 at 14:38
  • How to do the above. Hold shift while booting, press E while highlighting the main Ubuntu boot line, then add nomodeset to the end of the line that starts with linux. – OregonTrail Feb 19 '13 at 16:57

Uninstall ATI driver

$ sudo sh /usr/share/ati/fglrx-uninstall.sh   (if file is existing)
$ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Install free driver

$ sudo rm /etc/X11/xorg.conf
$ sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 xserver-xorg-core
$ sudo dpkg-reconfigure xserver-xorg


$ sudo reboot

Download ATI driver

$ mkdir ~/catalyst12.6/
$ cd ~/catalyst12.6/

To know what Graphic Card you have, do lspci -v | grep -A 12 VGA. Download the appropriate driver for your machine here from the AMD/ATI Website. File should be something like amd-driver-installer-12.6-legacy-x86.x86_64.run (not version 12.04 like in previous answer, 6 months earlier). Move it in ~/catalyst12.6/ . Unzip it if needed.

$ unzip amd-driver-installer-12.6-legacy-x86.x86_64.zip

Install ATI driver

$ sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot libqtgui4

$ sudo chmod +x amd-driver-installer-12.6-legacy-x86.x86_64.run
$ sudo sh ./amd-driver-installer-12.6-legacy-x86.x86_64.run --buildpkg Ubuntu/precise
$ sudo dpkg -i fglrx*.deb
$ sudo amdconfig --initial -f
Reboot and Check if installation is successful
$ sudo reboot
$ sudo fglrxinfo
   display: :0  screen: 0
   OpenGL vendor string: Advanced Micro Devices, Inc.
   OpenGL renderer string: ATI Radeon HD 4200 Series 

OpenGL version string: 3.3.11653 Compatibility Profile Context It is all good, as you can see, after last reboot, fglrxinfo displays my ATI Graphic card correctly.


Well I ended up giving up and transferring as much info as I could to a usb drive (via the terminal obviously) and completely reinstalling the operating system (with 12.10). For whatever reason it now works on a fresh build, and with all the same hardware and software that was on before. I don't know why the in-place upgrade from 12.04 to 12.10 causes failure but a clean install of 12.10 doesn't but I hope this helps someone out at least a little. Unfortunately I get to spend today rebuilding my web server from scratch.

Good luck!

  • I solved the problem, I edited in the solution to the first post. – Clintonio Nov 6 '12 at 5:56

I still have the same issue as yourself. Everything was working fine until I upgraded to 12.10. I've followed so many tutorials on how to delete video drivers, reinstall ubuntu-desktop and unity, completely purge fglrx, etc., and all to no avail. From what I understand we need to wait for ATI to make a driver that is compatible with 12.10. So I guess we wait.

  • 1
    Canonical should not have suggested that we upgrade when it clearly doesn't work. I was happy on 12.04. I think I'll reinstall 12.04 and stick with it till 14.04 at this rate. – Clintonio Oct 26 '12 at 10:51

Some "old" ATI cards are no more supported and their drivers are not updated, so an older version of Xorg. You shouldn't be affected, as your card is newer, but you may be.

So, I had the same problem with you and this worked for me... http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.