I just upgraded to 12.10 via a fresh install. Mounting my Xperia Neo V in 12.04 worked flawlessly however I just discovered that the sd card can't be detected and mounted in 12.10. How can I solve this? Thanks in advance.

P. S. I can mount it via a card reader though and it mounts ok in Windows 7. So it surely can't be hardware related.

EDIT: Sony Ericsson Neo V running Android 2.3.4. USB mass storage is already turned on.

  • 2
    is it android phone? if yes, have you turned on USB Mass Storage option. – BigSack Oct 28 '12 at 5:29
  • Is the phone using Android v2.3.x (Gingerbread) or have you upgraded to v4.0.x (Ice Cream Sandwich)? – david6 Oct 28 '12 at 9:55
  • Please provide a step-by-step protocol of what you do to connect the phone. – user98085 Oct 28 '12 at 10:03
  • I plug in the sd cable to both phone and laptop. Windows 7 easily mounts (12.04 too) the sd card but for some strange reason, 12.10 can't – Mysterio Oct 28 '12 at 12:07
  • run lsusb and post the output – Vikash Singh Nov 7 '12 at 17:11

Try connecting the phone with the computer first.

Then change the connection type to mass-storage.

Wait for some time like 5 minutes.

If it is still not working then try this..

Pull the usb cable just a little bit out from the computer side.. ( just a tiny bit) and wait for a couple of minutes..

if it starts working then you may push the usb - cable back in properly.

I faced similar issue..

If it still doesn't work then :(

| improve this answer | |
  • It didn't work unfortunately – Mysterio Oct 31 '12 at 19:20
  • The phone charges even though a usb connection can't be detected – Mysterio Oct 31 '12 at 19:42

It seems to be a kernel regression. This bug report covers the issue. Let's hope Canonical squashes this bug A.S.A.P.


Yet to verify but according to this bug report, the bug has been fixed. Update to the latest Ubuntu kernel via Software updater to rectify this problem.

Bug has been fixed with the latest kernel update

| improve this answer | |

I had the same problem with my Sony Ericsson Xperia ray connected by usb with my laptop running Ubuntu Gnome Remix 12.10. Tested with Suse 12.2 and (brrrrr) Windows XP - no problem there. After the news that Canonical would take over responsibility for kernel 3.5, I got the idea to update to a kernel from the 3.6-branch. I took the kernel 3.6.6 from UpUbuntu http://www.upubuntu.com/2012/11/install-linux-kernel-366-in-ubuntu.html and now it works again. The SD-card on my phone is showing up on the laptop and the phone is showing contact to the computer.

| improve this answer | |
  • 1
    It definitely makes sense as I'm sure Canonical did something to the Linux kernel which causes this situation. – Mysterio Nov 19 '12 at 17:29

I've just encountered the same issue with my Fly DS210 mobile phone with a SD-card. After plugging into the USB, it asks to choose the operating mode: flash-drive, webcam, serial, etc. After I choose Flash-drive, the phone hangs, nothing mounts and there appears a strange empty mounted directory inside /media.

The solution that worked in my case, was to uninstall the usb_modeswitch package. It handles such multipurpose devices, and switches them from usb-storage to usbserial mode.

| improve this answer | |
  • It didn't work unfortunately. – Mysterio Nov 2 '12 at 21:04

I faced the same problem with my Xperia Ray ICS because USB-connection mode was not set to mass storage. Now it works.

| improve this answer | |
  • This won't work with newer versions of android, but if Android offers UMS mode then by all means this is the best option. – coteyr Nov 29 '12 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.