I have the subject card recently installed in Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-31-generic x86_64). See partial lspci -vv listing below (complete listing played havoc with pre tags):

03:00.0 RAID bus controller: HighPoint Technologies, Inc. Device 0622 (rev 01)
        Subsystem: HighPoint Technologies, Inc. Device 0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 11
        Region 0: I/O ports at 9c00 [size=8]
        Region 1: I/O ports at 9800 [size=4]
        Region 2: I/O ports at 9400 [size=8]
        Region 3: I/O ports at 9000 [size=4]
        Region 4: I/O ports at 8c00 [size=16]
        Region 5: Memory at fdbff000 (32-bit, non-prefetchable) [size=2K]
        Expansion ROM at fdbe0000 [disabled] [size=64K]

I followed instructions I found at https://help.ubuntu.com/community/RocketRaid to compile the drivers for it, and although performing the process described there seemed to work fine with no noticeable errors, when I rebooted after performing that procedure I could not boot.

During dkms steps, I noticed messages indicating that (If next boot fails, revert to initrd.img-3.2.0-31-generic.old-dkms image) update-initramfs................

so I booted using a Ubuntu 12.10 LiveDVD and reverted to the old-dkms initrd.img as suggested above, but this failed to repair the boot problem.

Ultimately, I used https://help.ubuntu.com/community/Boot-Repair in Ubuntu-Secure-Remix to fix the boot problem and was able to boot normally again, but now with the newly generated initrd.img in place again (which now boots normally), when I modprobe the rr62x kernel module, I immediately get a hard crash with messages to console about a kernel paging request that seems to have caused the problem.

I've tried on multiple occasions now to use the newly built kernel module so as to allow me to use an eSATA port multiplier plugged into the card, but to no avail.

Any suggestions on fixes or workarounds (I've read that some of the HighPoint cards (2720SGL) seem to work as a host bus adapter and thus may not need a custom driver, but that seems not to be the case for mine) would be most appreciated. My goal is to use the card as described here and with software RAID mdadm utilities.

If necessary, I can hand-copy the console messages after the hard crash into a follow-up message, but I obviously can't do a cut/paste. I'll gladly provide any other details that are needed, but not sure what those would be at this point, so I'll refrain from adding other details for now.

Thanks in advance for any help.


Well unfortunately, this issue is more complicated than it appeared to be two days ago when I answered my own question and thought I had the issue resolved.

Although upgrading the kernel did allow me to finally boot the kernel and load the rr62x module without an obvious machine lockup/crash, I was never able to actually use the hardware, and upon more investigation of this today, I now see that this rr62x module generated a kernel oops:

Nov  5 10:06:38 hp2home kernel: [   19.360006] rr62x:[0 1 3] device probed successfully.
Nov  5 10:06:38 hp2home kernel: [   20.395211] scsi8 : rr62x
Nov  5 10:06:38 hp2home kernel: [   20.395777] BUG: unable to handle kernel paging request at 0000000000050005
Nov  5 10:06:38 hp2home kernel: [   20.395798] IP: [<ffffffffa01d3543>] hpt_queuecommand_lck+0xd3/0xf30 [rr62x]
Nov  5 10:06:38 hp2home kernel: [   20.395820] PGD 1b0465067 PUD 1b0464067 PMD 0 
Nov  5 10:06:38 hp2home kernel: [   20.395827] Oops: 0000 [#1] SMP 
Nov  5 10:06:38 hp2home kernel: [   20.395834] CPU 1 
Nov  5 10:06:38 hp2home kernel: [   20.395837] Modules linked in: rr62x(PO) nouveau ttm drm_kms_helper drm i2c_algo_bit mxm_wmi video hid_generic usbhid hid wmi sata_sil24 pata_marvell forcedeth sata_nv
Nov  5 10:06:38 hp2home kernel: [   20.395867] 
Nov  5 10:06:38 hp2home kernel: [   20.395870] Pid: 298, comm: scsi_scan_8 Tainted: P           O 3.5.0-17-generic #28-Ubuntu Hewlett-Packard HP Compaq dx2450 Microtower/2A72h
Nov  5 10:06:38 hp2home kernel: [   20.395883] RIP: 0010:[<ffffffffa01d3543>]  [<ffffffffa01d3543>] hpt_queuecommand_lck+0xd3/0xf30 [rr62x]
Nov  5 10:06:38 hp2home kernel: [   20.395896] RSP: 0018:ffff8801b1471990  EFLAGS: 00010202
Nov  5 10:06:38 hp2home kernel: [   20.395902] RAX: ffff8801b071b400 RBX: ffff8801b071b400 RCX: ffff8801b06c00f0
Nov  5 10:06:38 hp2home kernel: [   20.395908] RDX: ffff8801b071b600 RSI: 0000000000000000 RDI: ffff8801b06c00d8
Nov  5 10:06:38 hp2home kernel: [   20.395915] RBP: ffff8801b14719f0 R08: 0000000000000000 R09: 0000000000000024
Nov  5 10:06:38 hp2home kernel: [   20.395922] R10: 0000000000000000 R11: 0000000000000024 R12: ffff8801b06c00d8
Nov  5 10:06:38 hp2home kernel: [   20.395928] R13: ffff8801b05ae800 R14: ffff8801b06c0000 R15: 0000000000050005
Nov  5 10:06:38 hp2home kernel: [   20.395935] FS:  00007f3bf573f700(0000) GS:ffff8801bfc80000(0000) knlGS:0000000000000000
Nov  5 10:06:38 hp2home kernel: [   20.395943] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Nov  5 10:06:38 hp2home kernel: [   20.395949] CR2: 0000000000050005 CR3: 00000001b0480000 CR4: 00000000000007e0
Nov  5 10:06:38 hp2home kernel: [   20.395955] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Nov  5 10:06:38 hp2home kernel: [   20.395963] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Nov  5 10:06:38 hp2home kernel: [   20.395970] Process scsi_scan_8 (pid: 298, threadinfo ffff8801b1470000, task ffff8801b14f1700)

Furthermore, the presence of the rr62x module in the kernel also seems to have caused problems with my other RAID card (RAID bus controller: Silicon Image, Inc. SiI 3132 Serial ATA Raid II Controller) as with rr62x in the kernel, any time I booted the machine with the first (the original post was about a second PMP plugged into an add-on RAID card) PMP powered on, the machine would lockup during boot up, and when I boot the machine without the first PMP powered on, it completes boot up (although with the aforementioned oops in the log).

I've since run sudo dkms remove -m rr62xla -v 1.0 --all and now I boot with no problems with the first PMP and no oops, so it's pretty clear that the rr62x module is the problem, but it sure looks like other people are using it without problems, so if anyone has any further ideas, I sure would appreciate seeing them. Alternatively, since the original post got so little attention, I'm wondering if these types of problems are beyond the scope of this particular forum, and if anyone has ideas regarding the best place to ask this question, I'd welcome seeing those too.

Lastly, could someone explain this bounty business a little better? I read the documentation on this site about bounties, but I had the impression that by answering my own question, I would have the option of awarding myself the 50 rep points that I put on the original question, and now I'm finding that's apparently not the case? It's no big deal, but I'd like to understand how this bounty thing works better, in particular when the OP answers his own question. TIA.

  • 1
    Questions about the site - and that includes how a bounty works should be asked on Meta - not on the main site. You dont get your bounty back if you answer your own question. Think of it as "advertising" - you spend it to get your Q more notice - you dont get your money back since it has been spent.
    – fossfreedom
    Nov 5, 2012 at 17:21

1 Answer 1


I don't know why this worked, but upgrading my kernel from 3.2.0-31-generic to 3.5.0-17-generic seems at first blush to have solved the problem. I at least now have the module loaded and the port multiplier powered on without immediately crashing the machine. The jury is still out (waiting on me finding time for thorough testing) on robust operation of the hardware, though.

  • that makes sense - can you add to your answer what kernel version you were using and what version of the kernel you are now using?
    – fossfreedom
    Nov 3, 2012 at 12:48
  • curious: why does that make sense to you? it doesn't to me. the original how-to describes the hardware/driver working with several older versions of ubuntu...
    – TeXnewbie
    Nov 4, 2012 at 3:49
  • This always looked like a kernel issue - looks like the 3.2 kernel broke this capability, but was later fixed again in a newer kernel. Anyway - well-done. +1/
    – fossfreedom
    Nov 4, 2012 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.