28

I have two questions :

First, I wanted to hide Ubuntu’s side-bar, so I set the settings in appearance to 'autohide'. The side bar did indeed disappear but when I roll over the left side, the side bar don't appear again. So, I am using a virtual box. Can it explain the fact that this bar doesn't show again when it is set to autohide.

Second, assuming I wouldn't be able to come over the problem, I pined to the dock every element of the sidebar, except the dash home. Is it possible either to pin it in the dock or to launch it from the terminal ?

7

I'm using virtualbox too and I suffer the same problem, this is a virtualbox bug. The easiest thing you could do is to install gnome-fallback and use it instead of unity, since you're not using the unity dash anymore.

Check this link with details on how to switch to the default gnome desktop, if it's not installed by default, you can open a terminal and use the command:

sudo apt-get install gnome-session-fallback

Then you can change your desktop in the login screen:

enter image description here

51

Auto-Hide of side bar (or Ubuntu dock in 17.10 and later) in Ubuntu desktop can be easily done as following:

  1. Go to System Settings.
  2. Then go to Appearance (Dock in Ubuntu 18.04).
  3. Click on Behavior.
  4. Turn on the Auto Hide Launcher (Auto-hide the Dock in Ubuntu 18.04). By default it is off.
  • @ChristianF97 The title of the question is literally "Hiding the sidebar in Ubuntu". – kleinfreund Sep 19 '17 at 16:52
7

Above solutions don't work for Ubuntu 17.10+,

for Ubuntu 17.10 GNOME Desktop,

goto Settings>Dock>Auto-hide the Dock and toggle it to hide automatically.

also, you can customize the position of sidebar and icon-sizes.

  • on my 17.10 gnome desktop shell installation I couldn't find "Settings - Dock - Auto-hide the Dock", but in gnome-tweak-tool, there is the option "Extensions - Ubuntu dock" which does the job also – Hartmut P. Apr 7 '18 at 17:07
1

Using GNOME Fallback is one way to work around this problem, but there are other workarounds that also merit consideration.

It is worth noting that if anyone wants to use a GNOME2 style desktop instead of the default Ubuntu desktop, then you should know that the MATE desktop is available. It IS (a fork of) Gnome 2, it is just not called Gnome 2 anymore to avoid conflict with Gnome 3.

That is worth knowing, because although MATE is certainly a bigger download than only installing Gnome-fallback, the difference is that IF you install MATE you will have a fully functional Gnome-2 style desktop that can do everything that you could do in Gnome-2, whereas Gnome-fallback desktop does not provide quite that much.

But if you don't care about having as much as you get with MATE, then Gnome-fallback works too.

Lastly, but not least, Gnome 3 really is a usable desktop too, IF you learn -all- the keyboard shortcuts. (Look them up some time, if you want to get good at Gnome 3.) And remember that Unity is getting better and better with each release also.

1

I adjusted the sensibility in "appearances" to "high" because on my other computer I had the same problem with the side bar that was hard to get out again. Now it works fine.

1

Ubuntu 18.04

Toggling on the setting Settings > Dock > Auto-hide the Dock hides the dock as the setting hint says i.e The dock hides when any windows overlap with it, however when switching back to the Desktop the Dock appears. In earlier versions like Ubuntu 14.04 there was following setting System Settings > Appearance > Behavior > Auto Hide Launcher enabling which the Dock auto-hide on Desktop as well and could be accessed by hovering the Dock position, which is by default Left. To restore the desired behaviour on Desktop as well I followed the steps below I found at https://discourse.ubuntu.com/t/ubuntu-dock-add-true-autohide-option-to-default-session/11200/4 which worked spot-on

you can use dconf editor GUI to access all the features of Ubuntu Dock. They are located here: org.gnome.shell.extensions.dash-to-dock The parameter you need to activate “true autohide option” is intellihide.

To quickly enable it, you can use the following command:

gsettings set org.gnome.shell.extensions.dash-to-dock intellihide false

After that, turning on autohide option in System Settings will activate “true autohide” instead of the default intellihide.

To get things back just obviously run

gsettings set org.gnome.shell.extensions.dash-to-dock intellihide true

-1

Just auto hide the task bar and set the sensitivity all the way down to low and it wont pop up again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.