I installed CCSM to enable window previews in Unity. But when I went into extras, there was no 'window preview' option.

So I tried experimenting with other options in Compiz and now there are no borders in the dialogue boxes (close, minimize, restore buttons are not there, I had enabled some 'flat....' option in Compiz.

Later, I uninstalled Compiz and then reinstalled it. Now it says

"Failed to load session Ubuntu"

I can't even access through the guest account, I am new to Ubuntu.(please explain in detail).

All I have access to is the login screen (it still shows my custom wallpaper). Please help, I don't want to lose my stuff.


I got the same problem ""Failed to load session Ubuntu"" when I was trying to login afer uninstall Compiz.

I tried to boot from USB with Live Ubuntu inside and others ways but it doensnt work.

At the end, it comes up with a simple solution.

  1. Boot your Ubuntu as normal
  2. When you see the log-in screen, try to Ctrl - Alt - F1
  3. In my case (ubuntu 12.10), a blank screen appears. dont be panic, try Ctrl - Alt - F2
  4. A login console shows up and ask you to login using your id and password.
  5. After login. Run these commands. (tested)

sudo apt-get update
sudo apt-get install unity-2d
sudo apt-get install ubuntu-desktop
sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-plugins-extra
sudo apt-get update

I got this above list of commands from How can I remove and re-install Unity? but some doesnt work so I mentioned only good-running command in my case. I highly recommend to restart your system before try to login again.

sudo shutdown -r now

Hope it helps you to solve your problem.



Open virtual console : Ctrl+Alt+F1

sudo apt-get update

sudo apt-get install ubuntu-desktop

sudo apt-get install -f install

sudo dpkg-reconfigure ubuntu-desktop

sudo reboot

Then try to login, This will bring back your desktop

  • sudo dpkg-reconfigure ubuntu-desktop did the trick for me, thanks! – legends2k Jul 30 '13 at 21:34
  • Very good. sudo apt-get install ubuntu-desktop did the job for me because I updated ubuntu OS – Onimusha Dec 17 '13 at 15:15
  • This had no effect for me. – Cerin Oct 1 '14 at 5:59

For me it seems to have been related to having a Cinnamon desktop installed that I was playing around with. Once I removed it using Failed to load session "ubuntu" - Ubuntu 13.10 on MacBook Pro everything was fine. ( I don't have a macbook pro, it was the same on my Dell desktop).

  • Same here. I removed cinammon as package, but a bunch of dependencies were still there. So I started removing cinammon-session, cinammon-desktop-data, etc. – grosshat Apr 23 '14 at 12:19

Try booting into the LiveDVD and install Compiz. It's possible that you disable Unity. Update Unity.

Add the following PPA to your Software Sources per these instructions: ppa:unity-team/staging sudo add-apt-repository ppa:unity-team/staging

After adding, open the 'Software Updater', click ‘Check for Updates’, and proceed to install those you’re prompted to do.

This can also be achieved via the Terminal by running:

sudo apt-get update && sudo apt-get dist-upgrade

Restart your computer.

  • I cant install compiz – harsh Oct 24 '12 at 18:33
  • What's the error message? – TomKat Oct 24 '12 at 18:34
  • there is no internet – harsh Oct 24 '12 at 18:35
  • i have booted in the live dvd just now – harsh Oct 24 '12 at 18:35
  • what i cant connect to the internet on that machine – harsh Oct 24 '12 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.