The new web apps feature is fun, I've set up everything as it should be, but Empathy still doesn't connect to Facebook.

When I go to the "Online-accounts" dialog and open the Empathy options dialog in the Facebook tab this shows up:

  • Identification is blank and can't be edited
  • Alias is blank, but can be edited
  • A notification saying "Go online to edit your personal data" is visible

I've tried logging into Facebook using my email address AND my username, both with the same results.

  • Is this in an upgrade from 12.04? If so, try deleting the old account information from Online Accounts and click Add to create a new one. – user68186 Oct 24 '12 at 12:22

Go to your account settings on Facebook and disable the Login Notifications (Security Settings). Then, try to login on Empathy. Worked here!!

  • This did not work for me. – ams Jan 4 '13 at 14:38

I had the same problem. I've fixed it by deleting the old "Jabber" Facebook account entry, and adding a new "Facebook" account.

The new type requires you to log into Facebook via a browser-like interface, and register Ubuntu as a Facebook app, complete with app permissions and so on.

Presumably this is because the central online account is also used by Gwibber, to posts statuses, and Shotwell, to upload photos.


Here is something simple using Jabber configuration in empathy messenger: Start empathy and choose Jabber from the Accounts menu or press f4.
Now you need to go to: https://www.facebook.com/sitetour/chat.php and you will need to log into your facebook account from here, next you will click "other-Windows/Mac/Linux" This will bring up a configuration pop-up for YOUR Facebook account.

By default (since there are no port configurations that i know of) all you need it this:

  • Jabber ID: <username@chat.facebook.com>
  • Password: <your facebook password>

and there you go, you are now logged into Facebook.


I had the same problem in my Ubuntu 13.04. What I did was I ran the ff command:

sudo sed -i.bak "/<setting name=\"ClientId\">/a\          <setting name=\"AllowedSchemes\" type=\"as\">\['https','http'\]<\/setting>" /usr/share/accounts/providers/facebook.provider

It worked fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.