My 12.04 system hangs at "Checking battery state". At this stage, no commands work eg: Ctrl+Alt+f1, or Alt+f5.

I ran recovery mode, and ran the following commands:

sudo mount -o remount, rw /
sudo dpkg-reconfigure gdm

gdm was the only display manager installed, so I didn't get a GUI screen. I have an integrated graphics card "Intel Corporation Mobile 4 chipset Integrated Graphics Controller (rev 07)".

So I cannot install Nvidia drivers as everyone else suggests. I have gone through several similar questions but everyone suggests reconfiguring gdm or reinstalling graphic drivers.

I ran the following commands to get the latest x-swat drivers:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade

The system still hung at the same line.

The other option is to re-install Ubuntu, which is out of the question, since we have a very specific install for our project where the settings are very hard to duplicate.

Suggestions/Comments welcome.


8 Answers 8


Answer from the OP:

We installed lightdm and it showed similar behavior, i.e. it halted at a certain step.

However, then it was possible to press ctrlaltF1 and then login. The problem that there was the existence of /etc/init/lightdm.override. Inside the file was the word manual.

This was how it was present on install of lightdm, and then running 'sudo dpkg reconfigure lightdm'. Upon removing this file the system went to the login screen with no problems!


Worked for me with Ctrl+Alt+F1 and then login. After this, I typed:

sudo apt-get install --reinstall lightdm
sudo dpkg-reconfigure lightdm

After this, I rebooted system and worked fine.


A solution is available here


Display manager was looking for gdm instead of lightdm.


In my case it didn't have anything to do with lightdm or battery state. It was the nvidia driver. I had to execute

apt-get remove --purge nvidia-3*

to remove ALL nvidia related packages. Then I restarted, and the desktop loaded in standard graphic mode. Then I reinstalled nvidia by

apt-get install nvidia-current

and after reboot, nvidia drivers worked again.


The disk was full.

It worked for me with Ctrl+Alt+F1 and then login. After this, I typed

sudo df -H

It showed me 100% hard disk full. I made some space by deleting the unnecessary files.

sudo reboot

I had the same problem, the system would hang just after that line, which as I figure it has nothing to do with the actual problem: the display manager.

I first logged in to the system going to another TTY screen ctrl-alt-f2 I first did the update and upgrade routine and after reboot it would still hang.

sudo apt-get update
sudo apt-get upgrade

After I tried doing a fix on the install by way of this command:

sudo apt-get install -f

still it didn't work it continue to hang after reboot. In fact it wouldn't let me shutdown manually, so after searching for more help

I tried a reconfigure on the debian packages with this command

sudo dpkg --configure -a

It still just didn't work That's when I found that the problem was related to de display manager Link: http://www.lamantia.org/archives/148 So I tried this other suggestion on replacing the default display manager with this command:

   sudo apt-get install gdm

contrary to the person recommending this my problem still wasn't fixed. How ever it did allow me to login with the Lubuntu GUI, when it entered the GUI I had lost the apps from the launcher, at least dash and Firefox were still there.

But I didn't care for this GUI, so I looked for another solution and I found this link: How can I add a desktop/GUI to a command-line Ubuntu installation? at How can I add a desktop/GUI to a command-line Ubuntu installation?

Then I realize that if the problem is the display manager what I really wanted back was my Ubuntu desktop, so I remembered that I one before installed the GUI Ubuntu desktop from the command line in a server setup, since what I wanted to do is save my actual settings because like others they are of particular nature or need it would install the GUI and leave every thing else de ssh, the ftp the other setting unchanged.

So I tried this command:

 sudo apt-get install ubuntu-desktop

After a while it finished and I rebooted, after trying to do shutdown now and not actually shutting down I had to do a soft reset with Ctrl-Alt- Del. And to my surprise it WORKED!. When it booted back up again it went in to the GUI, found my login accounts and allowed me to enter again.

Of course the apps were not in the launcher, but they are installed so I just used dash to prompt them, launched then and when running the app appears in the launcher so I just right click the mouse and locked them to the launcher. Each of them ( LibreWriter, Calc, Impress, sys Setting, Ubuntu Software Center and Ubuntu 1), I got them back and work as before. Also I have shutdown the GUI as normal and rebooted and it works fine now. And I didn't loose any other settings.

Hope it works for you guys. Sorry I ran trough the whole process I did.

But maybe one instruction alone doesn´t work unless you go trough them all.

You guys try it, maybe all you need is to just do the last one the

sudo apt-get install ubuntu-desktop

But if you try it and it doesn't work. Well go to the first one, which makes sense update and upgrade.

  • The accepted answer doesn't work for me but yours does. The last command which installs ubuntu-desktop takes a lot of time but it seems the main one. Apr 7, 2014 at 8:29

I have had this problem for more than 8 months now; it put me off using Ubuntu because the solutions never worked for all scenarios. I use a Lenovo x301.

The only solution I've found that seems to fix across all scenarios is the one below. It basically argues that the 'checking battery state' freeze is caused by broken dependencies:

After Upgrading to 12.04 I can't get to the login screen

The command below will fix the dependencies:

sudo apt-get -f install

This often does not succeed because of parsing errors in one of the files. The post below identifies the files that need editing.

I recommend using nano to edit the files

sudo nano filename

This link will show you how to use nano: How to edit files in a terminal with nano?

So from the top:

  1. Ctrl+Alt+F1 when stuck at cheking battery state
  2. Login
  3. sudo apt-get -f install
  4. If not successful use nano to edit where the parsing errors are (example below is most common):

    sudo nano /var/lib/dpkg/status


I had this problem in a VirtualBox virtual machine after upgrading from 12.04 to 12.10. The problem was with the display driver, and the fix that worked for me was to upgrade my VirtualBox guest additions. I'd been using an older version of the guest additions that had been working fine, but not after this upgrade (even though VirtualBox itself wasn't upgraded when this error appeared).

This is how I fixed it:

$ # First make sure the VirtualBox guest additions CD image is in the CD drive
$ sudo mount -t iso9660 -o ro /dev/cdrom1 /cdrom
$ sudo sh /cdrom/VBoxLinuxAdditions.run

And then after I rebooted, it worked fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.