I am on an Asus Zenbook UX32VD in Ubuntu 12.10. Both in 12.04 and 12.10 I haven't been able to change the mouse speed (i.e. the "sensitivity" in the mouse/touchpad dialog). I can change the slider, but nothing changes.

This is a big problem for me, since the mouse speed is somewhat slow. Any suggestions?

The problem is both for the touchpad and mouse.

  • I dont have this laptop - so hence this comment. Maybe this Q&A can help - askubuntu.com/questions/130217/… . If you type synclient you have some parameters such as MinSpeed, MaxSpeed & AccelFactor that you can play with. Good luck.
    – fossfreedom
    Oct 29, 2012 at 9:35
  • 1
    I have installed LXInput from Softwarecenter. It's for LXDE but works also unter Unity. Anja
    – user279152
    May 7, 2014 at 20:13

13 Answers 13


First we need to identify the input device ID to change the speed/sensitivity. Open a terminal and run this command:

xinput --list --short


abcd@abcd-abcde:~$ xinput --list --short

Virtual core pointer

↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]

↳ Logitech USB RECEIVER                     id=12   [slave  pointer  (2)]

My pointing devices are a Logitech USB RECEIVER and a Synaptics TouchPad. To list out device properties:

xinput --list-props "SynPS/2 Synaptics TouchPad"


Another option: xinput --list-props 11 as 11 is the number that is shown above in its parent property (SynPS/2 Synaptic TouchPad).

Now reduce it's property values to suit your need:

Device Accel Constant Deceleration (267):   2.500000

using this command:

xinput --set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 1.5


Another option: xinput --set-prop 11 267 1.5 where 11 is the device, just like from above, 267 is the id of the device property (Device Accel Constant Decleration) as you can see when device 11 is being listed all of properties being attached, and finally 1.5 is your desired speed.

You may have to play around with this number a bit to set it exactly as you need.

If you need to set this value automatically every time Ubuntu starts then:

create a .sh file


xinput --set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 1.5

change the file to executable :

chmod +x

and Put this in the start-up applications list.

Source : Configuring Mouse Speed manually

  • 2
    I now have the same problem for my wireless logitech mouse with unified reciever. I can change the speed in the same way, but max speed (1) is way too slow! Any suggestions?
    – Felix
    Nov 20, 2012 at 12:11
  • Try increasing the acceleration property. <"Device Accel Velocity Scaling" 5> . I also have a Logitech wireless mouse and i can't see any direct speed property. all i got is acceleration and deceleration. Please tell what speed property your device is showing and also try to increase the value of speed beyond 1 and see if that works.. Nov 21, 2012 at 4:35
  • I made the value 0.5 on ThinkPad e530c with Debian 8 and it's working sweetly :)
    – Baha
    Nov 13, 2015 at 15:26
  • 5
    Linux mint 18, Logitech 510, xinput says "property 'Device Accel Constant Deceleration' doesn't exist, you need to specify its type and format" Nov 17, 2016 at 17:27
  • 1
    is there anyway to increase mouse speed w/o using acceleration?
    – chovy
    Dec 3, 2016 at 9:28

Ubuntu 12.10 64-bit, Logitech cordless TrackMan

xinput did nothing for me.

xset q

to check settings

xset mouse 3 0

This sets the acceleration to 3 and the threshold to zero. Not great settings but better than before.

If you want to use fractional value, you can enter fraction (i.e. 3/2) instead of floating point number.

The man page says the settings will be lost on logout/reboot.

  • 10
    If you want to use fractional value, you can enter fraction (i.e. 3/2) instead of floating point number. It's weird, but it works.
    – R Burny
    Sep 2, 2013 at 1:16
  • hmm, so what is the fastest speed that xset can do?
    – Amos
    Jun 6, 2017 at 16:34
  • Thank you I was getting quite annoyed at my inability to manipulate bodhi linux mouse speed
    – 0x4f3759df
    Sep 17, 2017 at 16:03

The above mentioned "Device Accel ..." options do not exist on my machine. Lenovo T440s running Ubuntu 18.04

Instead, I have success using these:

xinput --set-prop "TPPS/2 IBM TrackPoint" "Coordinate Transformation Matrix" 0.5 0 0 0 0.5 0 0 0 1

The original "Coordinate Transformation Matrix was 1 0 0 0 1 0 0 0 1 and I have now half the speed, which is slow enough for me.

With this syntax, we can adjust horizontal and vertical speed separately.

  • 2
    Thanks for this. I have successfully used this to speed up my Logitech K520 mouse, so I wanted to mention that it appears to work for Logitech mice too. Oddly, the right-most number seems to slow down vertical scrolling at higher numbers, and speed up at lower ones. Sep 6, 2019 at 18:49
  • This approach worked well with a Microsoft Microsoft Wireless Optical Mouse, where the mouse was too sensitive to use while walking on a treadmill. Feb 21, 2020 at 19:49
  • 1
    My Microsoft Classic Intellimouse pointer was too slow on Ubuntu 20.04. The Acceleration and Sensitivity settings in the Mouse and Touchpad GUI were maxed out. xset did not have any effect. libinput Accel Speed was at it's maximum value of 1. I fixed it with xinput --set-prop 12 149 2 0 0 0 2 0 0 0 1, where 149 is Coordinate Transformation Matrix.
    – Nick Hope
    Oct 19, 2020 at 11:12
  • Yes, this worked also for me with a speedlink mouse, shown as ARESON Wireless Mouse. A nice post about the matrices is here: unix.stackexchange.com/a/177640/55508 Nov 13, 2023 at 14:33

You can use these scripts to set the touchpad and mouse speed each systemstart:

TP=$(xinput --list --short|grep -i touchpad|cut -f 1 | cut -d" " -f 5-|sed 's/\s\+$//g')
xinput --set-prop "$TP" "Device Accel Constant Deceleration" 1.5
xinput --set-prop "$TP" "Device Accel Velocity Scaling" 10

For me, I think 1.5 and 10 are suitable values for the touchpad.

I use a Logitech usb mouse too.
So for a Logitech mouse use this script:

MOUSE=$(xinput --list --short|grep -i Logitech| cut -f 1|cut -d" " -f 5-|sed 's/\s\+$//g')
xinput --set-prop "$MOUSE" "Device Accel Constant Deceleration" 1.2
xinput --set-prop "$MOUSE" "Device Accel Velocity Scaling" 10

For me, I think 1.2 and 10 are suitable values for the mouse.

I created a project on Github: https://github.com/rubo77/mouse-speed


Running sudo xset m 1 1 worked for me. My mouse speed now behaves in a normal behaviour like in Windows platform.


I've fine-tuned deceleration by closing my eyes, before moving pointer to a certain place on the screen. After 5 adjustments, now my mouse moves that much as I'm expecting.

That's the line I'm using right now:

xinput --set-prop "Bluetooth Mouse M557" "Device Accel Constant Deceleration" 2.3


As mentioned by others acceleration is not the same as speed. Until recently I used the Coordinate Transformation Matrix setting to scale the mouse velocity and disabled mouse acceleration with xinput. But this comes with its own issues - I had issues in Blender when doing mouse middle button drags to rotate the scene - The cursor was jumping as soon as I released the button. There is an open issue.

But I found a way to directly set the DPI of the mouse. It is possible to create a setting file here:

sudo vim /etc/udev/hwdb.d/50-mouse-dpi.hwdb

With the following content - Replace <name-of-the-device> with the name shown in xinput (e.g. "Logitech G700s Rechargeable Gaming Mouse").


To apply the settings execute

sudo systemd-hwdb update && sudo udevadm trigger

Repeat until you find a DPI value which makes you happy.

  • 1
    I wasn't able to get this to work with a Logitech mouse Jun 28, 2019 at 1:59
  • Tested with a Logitech MX Vertical and Ubuntu 20.04, it does not work. Apr 7, 2021 at 8:44
  • This did work for me with a Logitech Ergo M575 trackball and Ubuntu 22.04. Thanks! Adding HWDB entries for mice is documented in the comments in /lib/udev/hdwb.d/70-mouse.hwdb.
    – Mark L
    Aug 30, 2023 at 19:20

Using a live environment of 19.10, the following will set the max mouse speed.

gsettings set org.gnome.desktop.peripherals.mouse speed 1.0

To show all settings:

ubuntu@ubuntu:~$ gsettings list-recursively org.gnome.desktop.peripherals.mouse
org.gnome.desktop.peripherals.mouse middle-click-emulation false
org.gnome.desktop.peripherals.mouse natural-scroll false
org.gnome.desktop.peripherals.mouse speed 0.5
org.gnome.desktop.peripherals.mouse accel-profile 'default'
org.gnome.desktop.peripherals.mouse left-handed false

I used the 'simple' profile to increase the mouse resolution without acceleration.


device="Dell Dell USB Optical Mouse"
resolution_percent="241" # Greater than 100, use constant deceleration otherwise with profile -1. 

xinput set-prop "$device" "Device Accel Profile" 4 # Simple profile with threshold 0 allows constant scaling up
xinput set-ptr-feedback "$device" 0 "$resolution_percent" 100 # Set threshold to 0 and acceleration to $resolution_percent/100

You'll have to modify the script by using your particular device name. You can look that up by running xinput without arguments. Also the script has to be run each time the mouse is connected or when you start the system.


Just want to add to the previous answers that it's possible that there won't be "Device Accel Constant Deceleration" property. For example, I don't have it for Logitech G600 in Kubuntu 17.04. But there is "Coordinate Transformation Matrix" which is even more power


My Logitech MX518 mouse was too slow on Ubuntu 18.04. I tried to set Accel speed prop to max (1), but it did not speed it enough.

After some more searching, found lomoco (Logitech Mouse Control) and installed it with

sudo apt install lomoco

The man page is here http://manpages.ubuntu.com/manpages/xenial/man1/lomoco.1.html

The manual is good, but for a restless soul, this is what I did:

lomoco --scan

Got this as one of the output lines. c051 is the product ID.

002.004: 046d:c051 MX518 Optical Mouse (M-BS81A) Caps: RES

Then set the sensitivity

sudo lomoco -p c051 --1600

And got a fast mouse.


I'm running 16.04 on my Mac and xinput worked fine with Magic Mouse. The only thing I needed to do was run it as root:

sudo xinput --set-prop 14 271 3.0 

(I'm impressed how speedy was this mouse)

  • sudo is not necessary. this is a per-session setting Nov 13, 2023 at 14:21

I am running ubuntu 21.04 and changing the mouse speed is eeeeeazyyyy. This is not 12.10, but this is how you do it on 21.04 it will probably work on 12.10 if 12.10 is the same way. Here's how.

Click on the applications icon in the bottom left corner of the screen.

Search for Settings.

Click on Settings and go to Mouse & Touchpad.

There, it will have a Mouse Speed slider; slide it up like so.

enter image description here

That should do the trick if your gui is the same or similar.

  • Unfortunately, that only allows adjusting mouse acceleration even though the label claims to adjust mouse speed. Aug 12, 2023 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .