I upgraded from 12.04 to 12.10, my ethernet network card did not work, I tried to do the same procedure as did the version of ubuntu 4.12, but it didn't work.

Does anyone have a clue how to do it?

lo        Link encap:Loopback Local  
          inet end.:  Masc:
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:684 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:684 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0 
          RX bytes:66739 (66.7 KB) TX bytes:66739 (66.7 KB)

wlan0     Link encap:Ethernet  Endereço de HW e0:06:e6:d0:da:3d  
          inet end.:  Bcast:  Masc:
          endereço inet6: fe80::e206:e6ff:fed0:da3d/64 Escopo:Link
          pacotes RX:2040 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:2352 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000 
          RX bytes:1149462 (1.1 MB) TX bytes:307333 (307.3 KB)
  • do compiling in sudo mode, if you got errors
    – user80675
    Aug 1 '12 at 15:35
  • My system does not recognize any ethernet connection. Oct 24 '12 at 15:59
  • Post the results of the command: $ ifconfig
    – TomKat
    Oct 24 '12 at 16:55

OK, managed to fix the problem. I downloaded and installed compat-wireless-2012-02-28-p.tar.bz2 from http://linuxwireless.org/download/compat-wireless-2.6/ .

tar -xvf compat-wireless-2012-02-28-p.tar
cd compat-wireless-2012-02-28-p
scripts/driver-select alx
sudo make install
sudo modprobe alx

Note: This fix will NOT work with newer versions of compat-wireless-2012-02-28-p.tar.bz2. Alx was removed from newer versions. Use the exact file described here.

Update 2012/09/05: working on Dell Inspiron 14z with same chipset using the tarball compat-wireless-2012-09-01-pc.tar.bz2

  • 1
    Network(wired n wireless) are basic requirements of a OS. Engineering should do their best to ensure drivers are included in the OS. Otherwise, they should provide links in the webpage that point to media download. This is my feedback
    – user5545
    Jun 30 '12 at 3:31
  • This works for me on Lenovo G780, however after I restart the Ethernet does not work again and I need to do the modprobe alx again. Anyone have any idea why this is?
    – fiftyeight
    Jul 1 '13 at 14:05
  • you need to edit /etc/modules file, in order to load the module "alx" everytime you reboot. Just add the "alx" in a new line in that file. Sep 25 '13 at 4:55

In my case (Ubuntu 12.10 with Inspiron 14z), just installing the linux-backports-modules-cw-3.6-quantal-generic package solved the problem. Here's the magic command:

sudo apt-get install linux-backports-modules-cw-3.6-quantal-generic

If you can't run apt-get on your machine (because of the lack of a network connection) you can download the package here. This link is for the kernel - the latest in quantal. You may need a different verion of the package to match whatever you're running (see the output of uname -a).


Connect to internet.

Open dash by pressing ALT + F2 key

type in gksudo jockey-gtk and then press enter.

This will search for restricted driver and install them.

  • Tried, but couldn't find a suitable driver. It says "No proprietary drivers are in use on this system"
    – user5545
    Jun 28 '12 at 23:13

The driver compat-wireless-2012-02-28-p.tar.bz2 works well with my Ubuntu 11.04 "Natty" installed on my Toshiba NB510-117 PPL72E.

Here are the results of lspci:

01:00.0 Ethernet controller: Atheros Communications Device 1090 (rev 10)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Well, see if your system recognises the primary connection as eth1 instead of eth0. My laptop has only eth1, not eth0.

For this, open 'Network Connections' from the Unity Loader (press 'super' aka 'windows' key). Now, under 'wired tab', edit the connection you get.

Check 'connect automatically' and choose your IPv4 & IPv6 settings.

Unplug the cable. Plug cable again.

See if it works.


Current Quantal (12.10) users should not need to install backported drivers, as the 3.5.0 kernel now has built-in support for the alx driver.

For users on Precise (12.04 LTS), life became equally easy with the 12.04.2 point release on Feb 14th. That release introduced the LTS Enablement Stack, which will make your LTS release run atop the latest stable kernel (and X stack) from Quantal.

To enable the LTS Enablement Stack (it is default from 12.04.2 onward, but does not get activated automatically when you upgrade to 12.04.2 from 12.04 or 12.04.1), install the linux-generic-lts-quantal package:

apt-get update
apt-get install linux-generic-lts-quantal

If you also want the X stack from the Quantal release, additionally:

apt-get install xserver-xorg-lts-quantal
  • I am using Ubuntu 12.10 with same wired connection hardware. And it is not working. Can you please tell me how make it work without enabling the backports-modules. Because once I have tried to install from backports-modules and it creats some problem for me. It will be a great help for me.
    – Apurba
    Mar 15 '13 at 9:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.