I tried to upgrade from 12.04 -> 12.10. The install seemed to go well but upon reboot, I get the grub recovery console.

I tried to reinstall using the boot-repair Boot Repair

which usually works a treat. However this time it says it is scanning my HDD and never recovers.

When I try to reinstall grub from the liveDVD using the old

    grub-install <dir> <dev> --recheck --debug &> gruboutput.txt

I get this

Pastebin link

I think it should be installing to dev/mapper/isw_gbaaebhfe_Volume0 even when I made --> dev/mapper/isw_gbaaebhfe_Volume3

Any help would be appreciated

  • Please run Boot-Repair --> Recommended Repair , then indicate the new URL that will appear. Reboot and tell us what you observe. – LovinBuntu Oct 29 '12 at 8:10
  • It doesn't get that far. When it starts it says its scanning my hardware and doesn't ever get any further. – Caustic Oct 29 '12 at 13:10

Create Boot-Repair-Disk would be better option. You can download it here.

  • okay I'll give that a try when I get home. Thanks – Caustic Oct 24 '12 at 6:00
  • It will 100% work. – Ketan Patel Oct 24 '12 at 6:07
  • It did not work. It doesn't have raid drivers. – Caustic Oct 30 '12 at 3:03
  • Sorry I don't understand. How do I do that? – Caustic Oct 30 '12 at 5:40
  • check out this askubuntu.com/questions/43036/… for raid – Ketan Patel Oct 30 '12 at 5:48

IF you fail to see the Grub:- Insert a Ubuntu 12.10 Live-CD/DVD and run the following commands:

$sudo mount /dev/sdXY /mnt # XY is the drive, eg. sda or sda1

$sudo chroot /mnt

$sudo grub-install /dev/sdX #X is drive number

$sudo update-grub # Note that you just need to enter the 'drive' identifier here, not the partition!

Reboot and take out the LiveDVD. Lemme know if it doesn't work as intended.

  • This is not working in Ubuntu 12.10. – Ketan Patel Oct 24 '12 at 4:36
  • In that case, he'd have to use a Boot Repair Disk. – TomKat Oct 24 '12 at 4:43
  • I didn't explicitly say so in my question - I have now edited - but this is what I did using the liveDVD. @K.K Patel. is this a known bug? – Caustic Oct 24 '12 at 5:59
  • Yes, it is Bug with Grub but not more known. – Ketan Patel Oct 24 '12 at 6:05
  • One tip that just 'might' work: Most OSes are known to be problematic with a specific system. Try installing on you HDD y connecting it to another machine. For eg, my laptop always fails to install FreeBSD (so does all my friends' who use same system). But, it works fine when I install it on my HDD by plugging it into my desktop! Try it. – TomKat Oct 24 '12 at 6:14

you can also have ultimate boot cd on hand run super grub it will allow you to boot the os then run sudo update-grub from the os

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.