I've been having some strange issues with what also seems to be a resolution issue. Some sites load (very slowly), others time out. Not sure how to troubleshoot this one but would appreciate help, and will update my question with more data as it's requested.

What I've tried:

dpkg-reconfigure bind9-host : read about this in a seemingly related post

dig @nameserver-ip askubuntu.com

; <<>> DiG 9.8.1-P1 <<>> @nameserver-ip askubuntu.com ; 
(2 servers found) ;; global options: +cmd ;; connection timed out; 
no servers could be reached


I recently tried to upgrade to 12.10 directly from 12.04. This failed for whatever reason, to grub rescue. Allright, no problem, on another computer I get a usb key setup for installation, install (delete everything).

Load up, connect to wifi, no problems to speak of, install goes smoothly. After which, I didn't use the machine.

Now, this is a fresh install, so why is my DNS set to Google (, Strange indeed. But, perhaps a fragment from the previous install. And not my actual question but noted just in case it's relevant.

  • I'm confused as to how this could be an artifact from a previous install if this is a fresh install. Did you add that on a previous version on the same filesystem? – belacqua Oct 24 '12 at 2:33
  • First, I tried to upgrade. When that failed (grub rescue), I "delete everything and install Ubuntu" from the install menu. So yes, I'm confused as well. Yes it was set that way when 12.10 was installed. – Brandon Bertelsen Oct 24 '12 at 2:36

Have you checked the network manager connection settings under [Network icon]->edit connections->[your connection]->edit->IPv4 settings?

If the DNS domains/addresses are hard coded to google's DNS there, you can try selecting the "Automatic(DHCP)" option in the "Method" dropdown and saving the connection?

Try: dpkg-reconfigure bind9-host and then rebooting.

  • It's strange because it IS set to automatic and it IS showing google DNS. – Brandon Bertelsen Oct 24 '12 at 2:33
  • So it doesn't say "Automatic (address only)" and still honors the value in the text box? That is strange... Here's how to get rid of it - Select "Automatic (address only)" from the dropdown, that should make the field editable. Delete the values, select "Automatic" back in the dropdown menu and save the settings. – sahas Oct 24 '12 at 2:44
  • No, it says automatic(DHCP) and there is nothing in the box - yet, connection information shows – Brandon Bertelsen Oct 24 '12 at 2:46
  • There are no values in the field to which you refer - that's why I'm puzzled by this. – Brandon Bertelsen Oct 24 '12 at 2:46
  • 1
    I rebooted, and everything seems to be working fine now anyways. Another mystery. – Brandon Bertelsen Oct 24 '12 at 3:03

For future reference, I've had the same problem and found my solution here:


In short, it turns out conflicting services are fighting for your dns which means Network Manager doesn't always win.

apt-get purge rdnssd apt-get purge resolvconf service NetworkManager restart

Sorted it out for me. Note that your might not have rdnssd or resolvconf installed but if one of them IS, its redundant as Network Manager does their job anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.