In upgrading 12.04 to 12.10 via system upgrade when the system rebooted all I got was my desk-top without any command icons. Now all my files are locked into 12.10 and no way to retrieve them. I finally reinstalled 12.04 in a new partition but I don't have the knowledge on how to access 12.10 from it. Being a newbie with Linux I feel like I have all thumbs. I'd like to correct 12.10 but have to idea on what the problem is or how to access it. HELP!!!

Video card is a PNY GeForce 4 MX440 8x on an intel motherboard, so fglrx is not the issue

  • May i ask? you say you reinstalled ubuntu 12.04 again and removed 12.10 what option u used to install 12,04 it waqs install together with 12.10 or completely remove 12.10 and make fresh install? Or you managed hard drive? – polarkatenuchie Oct 23 '12 at 17:15
  • I didn't remove 12.10; I repartitioned and loaded a fresh install of 12.04 along side. When I originally upgraded to 12.10 I used 12.04's upgrade manager. – Toscano Oct 23 '12 at 17:37
  • once i had problems upgrading to new release the were errors cause electricity turned off i fixed it with restore option in grub menu.I enebled networking in restore options and fixed packages.It fixed all upgrade errors and did the rest. Also user can try sudo apt-get update -f and ,apt-get -f install.You can try to finish upgrade. Try sudo apt-get install --reinstall ubuntu-desktop, sudo apt-get install reinstall unity , unity --replace and check if ubuntu unity plugin enabled in ccsm – polarkatenuchie Oct 23 '12 at 17:43
  • I can't do any of that...I don't have any frames or sidebars when I attempt to load 12.10, just the empty desktop. – Toscano Oct 23 '12 at 17:47
  • You can press hold shift at system startup right? For other commands you can summon the console with cntrl+alt+f1 login and try there..Or use terminal with cntrl+alt+t – polarkatenuchie Oct 23 '12 at 17:55

You're right, your issue isn't with fglrx as fglrx is used by AMD/ATI GPUs. Your problem is caused by nVidia Drivers.

Run the following command to remove them, and reboot:

    `$sudo apt-get purge nvidia-current
    `$sudo apt-get remove nvidia-current-updates
    `sudo apt-get remove nvidia-experimental-304

Or just open Synaptic and search for nvidia, delete everything that you see now.

Reboot the system. See if everything's working. Run this command to check if Unity-3D will work:

$ /usr/lib/nux/unity_support_test -p

Reboot again. Reinstall latest nVidia drivers:

$sudo apt-get install nvidia-current-updates

  • Thanx, TomKat...I tried your solution and it exposed that it hadn't even loaded hte Nvidia files?? So I went straight to the install line and I was able to get my icons showing on the desktop but the sideboard and the top panel doesn't load at all. In searching through terminal I discovered that it doesn't have Unity loaded either. This was an upgrade through 12.04. Is there anyway to clean up the program without losing all my files? – Toscano Oct 24 '12 at 19:26
  • Hmmm... Clean up which 'program'? Run unity in terminal at once. If it doesn't run, I'd tell you how it can be installed. – TomKat Oct 25 '12 at 14:30
  • "Hmmm... Clean up which 'program'?" I meant the the entire 12.10 dist. I did go into terminal and typed "Unity" (correct action?) which then proceeded to give me an entire list of operations all of which were removed because of, mainly, (the reasons given) "Error: Plugin 'open GL' not loaded." and GLK is missing on display ":0.0". Haven't got the slightest idea what that means. – Toscano Oct 25 '12 at 16:53
  • I guess you mean GLX missing. Which GPU drivers are you using? Run sudo apt-get purge nvidia-* and sudo apt-get purge fglrx. Reboot and run $ /usr/lib/nux/unity_support_test -p See what happens. – TomKat Oct 26 '12 at 14:08
  • The message I received was "Error: GLX is not available on the system." After rebooting, the sidebar and top bar became visible and operational although as slow as cold molasses. Is this speed normal? I hope not. Are there any printouts I can post to give a clearer picture of the problem? – Toscano Oct 26 '12 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.