Possible Duplicate:
Desktop does not show when I installed nvidia drivers!

Yesterday, I have installed and updated Nvidia driver from Ubuntu Software Center. After restarting my PC launcher disappeared like in screen:

enter image description here

I have restarted, updated and re-installed Unity. But it doesn't work for me. I think there is problem with graphic/nvidia configuration.With Nvidia 520M

  • What is 11.20? It is 12.10? Or 11.10? – nanofarad Oct 23 '12 at 13:50
  • @LordofTime Most likely the OP switched the 1 and 2; it seems to be more probable to typo. – nanofarad Oct 23 '12 at 13:51

try go to compiz settings manager.To install it run command

sudo apt-get install compizconfig-settings-manager

and check if ubuntu unity plugin is enabled

enter image description here

also check decorating windows is enabled in effects. enter image description here

if not working you can try this

 setsid compiz --replace

and restart unity with

unity --replace
  • I have removed Nvidia (current) Driver from Software Center. It solved problem but I feel it's not updated driver which I'm using now? – Fatih Alp Oct 23 '12 at 14:45
  • without activated graphic proprietary drivers ubuntu works with open source drivers by default.If you want closed one google how to install supported nvidia drivers downloaded directly from nvidia site. – polarkatenuchie Oct 23 '12 at 14:49
  • I see but which one is better and updated? Nvidia seems to keep updated. But even I installed from Software Center there was big problem. I'm new with Ubuntu and afraid of possible problems after installing driver from nvidia. – Fatih Alp Oct 23 '12 at 15:03
  • I would try installing xswat updates to add ppa execute : sudo apt-add-repository ppa:ubuntu-x-swat/x-updates , sudo apt-get update , sudo apt-get install nvidia-current nvidia-settings ,from this tutorial upubuntu.com/2012/10/to-do-list-after-new-installation-of.html or else download close driver from nvidia site and google how to install it in 12.10 quantal. – polarkatenuchie Oct 23 '12 at 18:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.