I recently installed a fresh version of Ubuntu 12.10 on my notebook. Then I copied the backup copy of my Neverwinter Nights folder from my old 12.04 install on the same computer to the new installation and tried to start the game.

The terminal prompt disappears and top shows some low activity on nwmain, but there is neither showing up the game graphics nor plays any music.

Any suggestions how to fix it? The game runs fine using the same setup expect for running on 12.04.

Btw. I set up a virtual box with Ubuntu 12.04 on my notebook and use a copy of my Neverwinter Nights installation from the host (Ubuntu 12.10) to start the game. It works, I can play it under 12.04 64Bit Ubuntu in my virtualbox.

Kind regards and thanks in advance


If you have a fresh installation of Ubuntu, there are a few things you usually need to install before running Neverwinter Nights. You should cd to the nwn folder and run


(like you will have done when initially installing the game). This will check the game files and make sure you are ready to run the game. It is also worth manually checking that everything is executable that needs to be. (See also the bioware site for a good general tutorial and forum on Neverwinter Nights).

The most important dependency of the game is SDL, as we usually use the system SDL rather than the old, buggy version that comes with the client. So please enter:

sudo apt-get install libsdl1.2debian libsdl-sound1.2 libsdl-mixer1.2 libsdl-net1.2 libsdl-image1.2

You should also make sure you are using the following line in the nwn script in the nwn folder:


If you are using the movie patch as noted at the Bioware site, you will need to install the dependencies for the BinkPlayer.

sudo apt-get install libstdc++5 libx11-dev

I assume that you have the BinkPlayer executable in the nwn folder and the line

export LD_PRELOAD=./nwmovies.so

in the nwn script in the nwn folder.

If none of these suggestions fixes the problem, please cd to the nwn folder and run:

strace -o nwn.log ./nwn $@

(As you have done, you could also put strace -o nwnmain.log ./nwmain $@ in the nwn script and then run the script with ./nwn.) The resulting log files in your game folder might contain some useful information. As included by you in the comments, the logfiles are nwn.log and nwnmain.log.

After examining your log files and comparing (in particular) your nwnmain.log results to mine, there are some differences (although most of the unimportant errors are common).

  • You don't have open("./nwmovies.so", and all that goes after that, but you may not have applied the movie patch.
  • There are many ./lib references in your file and none in mine, so I wonder if there are any errant ./lib references in your nwn script.
  • Your file obviously terminates with a segfault, but I think the main problem is that the libraries cannot be found properly. You can confirm this by going to the nwn folder and running ldd nwmain.

In sum, I should make sure the game is set up properly (as I noted earlier in the answer), look for any errant references to ./lib in your config files, check that your libraries are being loaded properly (and if not perhaps add them to the nwn script with LD_LIBRARY_PATH), and check the permissions on your files are correct so that they will run properly.

  • Here is the output of the strace operation: nwn.log in addition I traced the execution of nwmain from inside the script too: nwnmain.log – 0x0me Oct 23 '12 at 20:31
  • @0x0me See my edit to my answer regarding these files. – user76204 Oct 23 '12 at 21:58
  • Game setup should be fine, because it is a copy of my under 12.04 working nwn install. You are right, I have not installed the movie patch. The output of lddlooks fine for me. Maybe I should point out that it is a 64bit install of Ubuntu, but that was the case for 12.04 too. – 0x0me Oct 24 '12 at 10:36
  • @0x0me Yes the ldd output looks good- I'm not sure what else to suggest, I'll have to think about it. – user76204 Oct 24 '12 at 11:08
  • thank - I hope you will have a good idea. Maybe someone out there has the same problem? – 0x0me Oct 25 '12 at 9:02

It does work on 12.10 64 bit and here is how I got it to work.

It should work for you as well, only I can't see the video even when it plays because of 64 bit.

  • but i can hear the sounds of the video's – vanquishedangel Nov 9 '12 at 23:40
  • I should edit your own post to include the extra info. – user76204 Nov 9 '12 at 23:41

@0x0me. I just tried the same thing as your original technique since I already had all the patches installed and working under 11.10. I know it has to work, but I could not get nwn to work using a copy technique in 12.10 - I messed around quite a bit with my install... it would just hang on the command prompt

I decided to abandon 12.10

upon reinstalling at 12.04 and updating patches as of 12/15, I added the following libraries: sudo apt-get install libsdl1.2debian libsdl-sound1.2 libsdl-mixer1.2 libsdl-net1.2 libsdl-image1.2 libstdc++5 libx11-dev ia32-libs ia32-libs-multiarch

Then copied my old nwn dir back in and happiness!

Everything looks good at 800x600. Will report back if there are any other graphics issues or any other strangeness.

  • Finally somebody can reproduce this - fine. I checked the software packages again, but all you installed in addition are already installed on my system. What kind of hardware you are using? – 0x0me Dec 23 '12 at 19:53

Turns out that the specific problem is somehow related to the graphics driver. If I use the i915 intel driver nwn crashes but if I change to use the proprietary fglrx amd/ati driver nwn runs fine but unity crashes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.