I am using Ubuntu 12.10 with Unity desktop. I go to TTY1 by pressing keys CTRL + ALT + F1, where I am asked to enter username and password, which I do, but I get the message "Login incorrect". In my log file /var/log/auth.log this entry has been made:

Oct 23 13:17:45 SomeName login[3361]: FAILED LOGIN (1) on 'dev/tty1' FOR 'aUser', Authentication failure

I do not have the wrong username or password. It is the same username/password I use to log in when Unity starts.

So how come I can't log in to TTY1?

  • 1
    Have you tried typing out the password once at the TTY (as the username, just to see what is displayed) and once when logged in (use the dash or somthing) just to see if this isn't a keyboard layout issue? Oct 23, 2012 at 11:35
  • Yeah it was a keyboard issue =) Numlock wasn't on! Oct 23, 2012 at 11:53
  • I was having a problem logging into tty*. I thought my login name was capitalized but i was wrong. For some reason its not. Switched to all lowercase and logged in fine.
    – user370293
    Jan 19, 2015 at 21:26
  • In my case this was caused by my login shell (/bin/zsh) not being listed in /etc/shells.
    – Zaz
    Jun 4, 2015 at 18:38

3 Answers 3


Perhaps your keymap configuration is wrong fo the tty (which is a different setting than Xorg / Unity) and your password is wrong because of this. Try entering your password when you're prompted for your username and see if the characters turn out right; don't press enter, but delete your input (since login tries get logged and your password would be in that logfile). If something is wrong, you must set the keymap. In unity, open the terminal application and enter

sudo dpkg-reconfigure console-setup

and choose the right layout there. You might have to reboot.

  • 1
    lol, funny thing. Numlock wasn't on and my password has some numbers in it =) Man do i feel dumb or what. Thing is I googled this issue of course and got all kinds of answers out there so I couldn't imagine that the solution was this simple =) Oct 23, 2012 at 11:52
  • I should also say why I want to log into another TTY. I am testing the echo command and now I know it works like a charm. For a newly weed like I am, login to a TTY of your choice, say TTY1, go back to the Unity terminal window and enter: echo test message > /dev/tty1. Oct 23, 2012 at 11:59

The most common cause of this error is simply typing your password (or username) wrong. The keymap in the console is often subtly different from the one in X.

Make sure you're typing the correct password by first typing it in the login field where you can see if it's being written as expected.

Check that you're typing your username exactly as it should be (including case), by comparing it to the output of whoami run in a terminal.

Another thing that will cause this exact same error message is if your login shell is not listed in /etc/shells. Find which shell you're using by searching for your username in /etc/passwd:

grep "dave" /etc/passwd

(replacing dave with your username) you should see something like this:


The last field (/bin/zsh) is your shell. Let's search for it in /etc/shells:

grep "/bin/zsh" /etc/shells

We should see something like this:


But if you don't, that's what the problem is. Try re-installing zsh (or whatever shell is missing from /etc/shells), and if that doesn't work, add it manually:

echo `/bin/zsh` | sudo tee /etc/shells

(we use tee because > redirection doesn't work with sudo)


Maybe the layout is different.Also to login in console you have to enter username wich can be different from your name in profile installation option.For example there is user profile name wich is Andrew but the user pc name can differ.See it here enter image description here I have my profile name on russian and when i login to console i use english login name. If the problem not in this try it http://www.noobslab.com/2012/02/reset-your-forgotten-password-quickly.html


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.