I try to compiled linux-nfc code, and running its configure file, but I get an error: configure: error: GLib >= 2.28 is required

I try to update the glib with apt-get install libglib2.0-0 libglib2.0-dev, but I get a message said my glib version is the newest. So I don't know how to update glib to 2.28. My Ubuntu version is 10.04.

  • 1
    Is there any reason why you can't upgrade? – Jan Hudec Oct 23 '12 at 7:26
  • I find there is a some problem, his question is here. Maybe my ubuntu version is too old. And it means i can compiled this source code with my PC now, so bad. – Sea turtle Oct 23 '12 at 7:30
  • That problem is rather weird; proper manual build of the package from newer release should work. Glib developers are rather careful not to break backward compatibility. Still you are likely to have more problems like this, so I suggest upgrading as the easiest and most reliable option. – Jan Hudec Oct 23 '12 at 7:33
  • Thanks Hudec's advices. I use command "apt-get install libglib2.0-dev", but my glib version always is 2.24.1. I don't know why i can't update glib newer version. – Sea turtle Oct 23 '12 at 8:37
  • Because Lucid only contains 2.24.1. You need to upgrade or add some kind of backports. But I only know where to find Debian backports, but not Ubuntu ones. – Jan Hudec Oct 23 '12 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.