I have a Gigabyte X85A-UD3R motherboard with an ICH10R. I also have a RAID 0 (striping) setup of 2x1TB disks, configured at the BIOS level (raid controler which boots before OS/after BIOS?) which merges the two physical volumes into one 2TB volume labelled MainVolume. The volume contains four primary partitions - two for Windows (boot and data) and two for Linux (root and swap), no logical partitions.

I had problems installing any Ubuntu after 10.04 on this setup. In fact, I installed 12.04 by installing 10.04 first and then upgrading. Ubuntu 10.04 worked flawlessly, but after upgrade to 12.04 it always displayed a message during boot in the console, something like "iwatch dm-5 failed" (not sure), but I didn't pay much attention to it because the system worked. Up until today's upgrade to 12.10.

Today when I upgraded to 12.10 at the end of the upgrade process it tried to install grub, and failed with the message:

Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting. 

Then the upgrade manager offered me to select a destination for GRUB - sda, sdb or MainVolume. When I select MainVolume it falls back to the above error message and asks again. I didn't choose sda or sdb, because I thought it might write to the physical drives as non-striped and mess up existing partitions. In the end I chose not to install grub and completed the upgrade.

I'm writing this now from that box which I don't dare to reboot since it might not boot.


Any ideas & sugesstions?

  • @K.KPatel: I don't see your post even mention fakeraid/dmraid... What makes you think it's a duplicate, the fact that grub-install fails? It can fail for any number of reasons.
    – Boris B.
    Oct 23, 2012 at 20:46

6 Answers 6


Maybe you should reinstall and update grub2? Or try boot-repair tool to fix issues. I dont know if it will work with 12.10 it worked with 12.04 just fine

  • Thank you, boot repair did it (seems it did grub-install ... --force).
    – Boris B.
    Oct 23, 2012 at 20:42

When I tried to install grub, it failed as well because it was defaulting /dev/mapper which is not an actual device.

I had to drop to BusyBox from the grub screen and ls /dev/m* showed a device called /dev/mapper/pdc_baagjii, so that's where I installed grub to, then rebooted no problem. Hope that helps you.

The install of grub failed because I wasn't certain of the device location. It was defaulting to /dev/mapper.

So I dropped to Alt+F2 and hit Enter key to enable ~BusyBox (which is the environment that the installer runs in).

I looked at mount | grep mapper output and saw that my root partion was listed as /dev/mapper/pdc_baagjii1 / ext4.

That meant my grub install location should be the device /dev/mapper/pdc_baagjii.

I flipped back to Alt+F1 to continue the installation and typed /dev/mapper/pdc_baagjii. I could also have typed grub-install /dev/mapper/pdc_baagjii.

After successfully installing grub at /dev/mapper/baagjii device location, I rebooted and was happy to see my Login prompt waiting for me.

  • Can you explain in greater detail what you did? Right now it seems unlikely that anyone who doesn't already know this solution would be able to apply it. Jan 9, 2013 at 23:52

Yes, it seems that the distribution upgrade script does not play nice with RAID0. I had a simple fresh 12.04 install with two SSDs as a single RAID0 drive, grub installation failed in a similar manner. Booting with a USB drive and using the boot-repair tool to reinstall GRUB resolved the problem.


had similar issue with a fresh install on 12.10 on a vertex 4. went through the whole boot repair etc

tried a reinstall, this time i added a /boot partition to the start of the drive rather than let ubuntu installer do its auto install. bingo, no problems, grub2 works and can boot into system.

hope that helps


I had a very similar issue. I upgraded from 12.04 to 12.10 and after the install I had the same issues as you. I've spent hours messing with various things trying to get this resolved, complicated by the fact that I currently can't boot from DVD/CD and my largest functional USB key that my main board will boot is < 120mb.

Finally I went back to trying super grub2 disk again and tried booting into Ubuntu using the 3.5.0-17-generic kernel instead of the 3.2 kernel I was previously on. Earlier, I was unable to boot that kernel due to it hanging before loading completely (I can't remember what exactly caused the hang) but it finally let me boot. I was then able reinstall grub-pc & dependencies as normal. Make sure you have some way to chainload into your install on the 3.5 kernel and maybe you'll be able to reinstall grub.


I had the same issue with a new 12.10 installation. The solution was based on the one presented by Matt, but it needed some further steps:

  • Select "something else" on the partition wizard to manually define the partitions.
  • Create at the start of the hard drive a 250 MB ext4 partition, mounted to /boot (set as primary)
  • Create the root and swap partitions
  • When the installation fails to install grub, choose to continue without installing it.

When the installation ends:

  • mount the "/boot" and "/" partitions manually
  • grub-install --boot-directory=(directory where the "/boot" partition is mounted) --root-directory=(directory where the "/" partition is mounted) (hard drive device)
  • umount the partitions
  • load "gparted", select the "/boot" partition, and activate the "boot" flag on the "manage flags" option. (Be sure to have this flag enabled, otherwhise the system won't boot).

After doing that, I was able to reboot and use the OS :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .