I have Pinnacle's Analog TV PCI card with remote (IR) controller. I want to use this remote controller to control XBMC.

I've read that I need LIRC daemon so I installed it (sudo apt-get install lirc) and selected Pinnacle Systems PCTV (pro) reciever as Remote control configuration (during LIRC setup). For IR transmitter I selected none (AFAIK I don't have it). Now the problems arise (cut out):

Setting up lirc (0.9.0-0ubuntu1) ...
ls: cannot access /lib/modules/3.2.0-23-generic/kernel/drivers/staging/lirc: No such file or directory
 * Loading LIRC modules                                                  [ OK ] 
find: `/sys/class/rc/*/': No such file or directory
 * Starting remote control daemon(s) : LIRC                              [fail]

Here is my /etc/lirc/hardware.conf. I've also tried this workaround

sudo ln -s /lib/modules/3.2.0-23-generic/kernel/drivers/staging/media/lirc /lib/modules/3.2.0-23-generic/kernel/drivers/staging/lirc

but it doesn't work.

How to make use of this remote control before I throw it out the window? :)


I had an issue with a Harmony Remote not working correctly. After walking round the internet for a few days, I came across this article on using ir-keytable.

After uninstalling LIRC, installing and configuring ir-keytable, I had the remote working as expected when running a trace using ir-keytable -t; however XMBC did not see the remote. After resinstalling the LIRC packages, XBMC worked correctly with no further configuration.

I don't know if it will work for you, but could be worth a try...


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.