I have a custom Ubuntu 12.10 configuration (started out as a minimal installation of Ubuntu 12.04 with a number of other packages such as Gnome Shell selectively installed via apt-get and then upgraded to 12.10). (Almost) everything works just fine. However, the lock screen (Gnome screensaver) does not expose a UI to control music playback. Whenever I have Rhythmbox running in the background I cannot pause music playback without unlocking the screen. Obviously some package(s) or configuration bits are not present but I am not able to figure out what needs to be added or done in order to enable playback control in the lock screen.

Any idea what I might be missing? Ideally I would not like to install Ubuntu desktop only to get music controls in the Gnome lock screen.


i think this should solve your problem:

execute the following command:

gsettings set org.gnome.desktop.screensaver show-notifications true

this will enable notifications ( music too ) for gnome-screensaver .

( for disabling run the same command with false at the end! )

i found that command somewhere while i tried to fix my own problem..

Note: This solution on currently works for Rhythmbox and may be deployed in a later version of Gnome (3.8?) (See ref: lock screen bug report)

  • I tried that suggestion and it works for notifications but not for music players? Is this only available for Rhythmbox or Banshee as well? – shaneonabike Nov 17 '12 at 15:07
  • I found the answer on the bug posting - bugs.launchpad.net/ubuntu/+source/gdm/+bug/1073385 - this feature of music only works for Rhythmbox and not Banshee until possibly Gnome 3.8 – shaneonabike Nov 17 '12 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.