I just upgraded my 12.04 based Dell Inspiron laptop to 12.10 but after the reboot I got a message saying system is running in lower graphics mode. But I'm still not able to access Unity and GNOME. This is with an AMD Radeon HD 7570M graphics card. How do I fix this issue?

3 Answers 3


I have Ubuntu 12.10 and was getting the same error, so I found this thread and only run:

sudo dpkg-reconfigure xserver-xorg 
sudo reboot

For now this was my solution, hope this help. Thanks!


try to go to console and remove the fglrx driver while in low graphic mode press Ctrl+Alt+F1 and login with your user name and password then run

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglRx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo reboot

and also i would recommend to reinstall ubuntu desktop with this command sudo apt-get install --reinstall ubuntu-desktop Maybe it will help.

  • hi I tried it just now, I was not able to see the UI still hanging out in console. Any other fix? Oct 22, 2012 at 17:26
  • so you removed the fglrx driver and rebooted and still get nothing am i right? Try to reinstall open drivers by executing :sudo apt-add-repository ppa:xorg-edgers/ppa ,sudo apt-get update , sudo apt-get upgrade ,sudo dpkg-reconfigure xserver-xorg , sudo reboot Oct 22, 2012 at 17:39
  • let me try this and get back to you then Oct 22, 2012 at 18:21
  • Its not working, after the reboot I got the tty itself. Oct 22, 2012 at 18:35
  • As a final try i would install 3.2.32 kernel via console to see if its fglrx problem cause 12.10 release has grapfic issues (some drivers dont work).3.2.32 kernel works 100 % with fglrx package by default in 12.04 lts. Then id try to install fglrx in console and boot 3.2.32 kernel(advanced option in grub). But all this optional cause it s only my guess that issue is in new kernel version 3.5.4 wich means you have to remove fglrx first to use it because the first rule before installing latest kernel vercion is to remove fglrx proprietary drivers or else it will be black screen. Oct 22, 2012 at 18:44

For Intel integrated graphics on Core processors, it seems that lightdm is the culprit and workarounds are add a delay in rc.local or install and use gdm. Launchpad seems to think that lightdm is too fast at querying for a display and people are saying SSDs can contribute to this race condition. Not sure if this would help you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .