It might sound stupid, but I don't know how to browse files on my device (phone) connected to Ubuntu machine via Bluetooth. I see that the connection is established, I can send files from my computer to the phone, but just can't seem to find how to browse the phone's file system.

I should mention that my Bluetooth adapter is Foxconn / Hon Hai, which hasn't been supported in Linux until recently. However, now I'm able to pair my phone with the computer, and to send files from my computer to the phone. What's not working is sending files from the phone to the computer and browsing phone files on the computer.

The reason why I'm asking this question is actually to check whether my Bluetooth adapter is still not fully supported, or I just don't know how to use it properly.

  • 1
    Not the best answer because I have not found a solution.. yet It seems to be a bug in 12.10. Bluetooth worked fine under 12.04. I can send files to phone but when I try to browse files, A window or white screen flashes for a second but that is it. You are not doing anything wrong. My bluetooth Bus 007 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode) I get this error in blueman (same problem in default viewer, without the error message) >Could not display "obex://[00:1B:AC:CC:84:B0]/". Error: Message did not receive a reply (timeout by message bus) >Please selec
    – user55138
    Oct 24, 2012 at 3:00

3 Answers 3

  1. Create a folder in `/media/mountpoint with root rights
  2. Install obexfs
  3. pair the phone with the PC
  4. Get the device MAC and mount it with obexfs:

    sudo mkdir /media/mountpoint
    sudo apt-get install obexfs
    hcitool scan

Scanning ...

8F:77:17:77:44:16 My Android Phone

obexfs -b 8F:77:17:77:44:16 /mountpoint

To unmount the device:

fusermount -u /mountpoint 
  • Hi fecub. Many thanks for your answer. But this isn't quite working for me. I forgot to mention that my Bluetooth adapter is the notorious Foxconn/Hon Hai. I''ve updated my question now. Oct 22, 2012 at 18:31
  • This allowed me to browse and transfer files from my old phone into the ubuntu machine.
    – Daniel
    Apr 1, 2016 at 9:23
  • 1
    Great. From blueman I got only "another operation is in progress" errors and could not get rid of it.
    – Harald
    Jun 30, 2018 at 12:36

ok then try this:

test before, if your usb dongle was recognized you test it with this command:

lsusb | grep Bluetooth 

if you get this message, its successfuly recognized:

Bus 003 Device 004: ID 1310:0001 Roper Class 1 Bluetooth Dongle

then install an another browser for ubuntu:

sudo apt-get install bluez-utils libopenobex1 bluez-tools 

after the installation, you must restart the bluetooth dongle with this command:

sudo /etc/init.d/bluetooth restart 

or with this command

sudo service bluetooth restart 

Details of the Bluetooth device is obtained with the command:

hciconfig --all 

if all is ok, install bluetooth applet

  • 1
    lsusb | grep Bluetooth gives nothing to me :D It only returns a blank line. So I guess my trashy Bluetooth adapter that's causing the fuss, right? By the way, it's not a dongle, it's my laptop's built-in Bluetooth adapter. In any case, I'll accept your answer, because it helped me figure out what I asked for. Thanks for your work. Oct 23, 2012 at 5:20
  • you're welcome and yeah thats right.
    – fecub
    Oct 23, 2012 at 8:03

Have a look to https://wiki.archlinux.org/index.php/Blueman and install the packages obexftp and obexfs.

Mounting Bluetooth devices

The instructions below describe a method for using different file managers with Blueman. The examples in this section focus on Thunar. If you are using a different file manager, substitute thunar with the name of the file manager you are using.

Create a file obex_thunar.sh with the following content:

[ ! -d ~/Bluetooth ] && mkdir ~/Bluetooth   
fusermount -u ~/Bluetooth
obexfs -b $1 ~/Bluetooth
thunar ~/Bluetooth

Now you will need to move the script to an appropriate location (e.g., /usr/local/bin). After that, mark it as executable with

chmod +x /usr/local/bin/obex_thunar.sh

The last step is to change the line in

Blueman tray icon → Local Services → Transfer → Advanced

to obex_thunar.sh %d. Done.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .