I tried all proprietary drivers for my NVIDIA GTS450 graphics card, and after rebooting my PC, i get a very low resolution, and no desktop environment. I've tried the experimental 304 version and both other available versions as well. I am wondering if it has to do something with my PC, or the drivers haven't been optimized to support 12.10 yet?


I had the same problem. I used the "Software Sources" utility to change the driver. The install seemed to complete without any error message. On reboot, I got a low resolution screen. However, the nvidia driver was not installed. I used apt-get to install it again, then I saw an error. It complained that kernel sources weren't installed.

Ensure that you have linux-source and linux-headers installed and try again.

| improve this answer | |

I have exactly the same Nvidia Graphic Card GTS-450 with Ubuntu 12.10. In the terminal:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

This package will install the 310.14 nVidia driver. They are still in Beta, but they are working pretty well on my system. Save your data first, and try it. Proprietary drivers didn't work for me and i re-installed Ubuntu 12.10. Bye!

| improve this answer | |
  • what is the source? I mean is it an official source? – Shahe Tajiryan Nov 5 '12 at 14:06
  • It is not an official source. It installs a new version of several components required to show things on the screen (the X.org server). It is quite good but always imply some risk. If you have a problem applying the previous solution you should check twice that you applied the previous one correctly (look the duplicated linK) before using this one. – Davisein Dec 6 '12 at 18:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.