After installing Ubuntu 12.10 I cannot boot my machine anymore. I get the following error.

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/mapper/isw_cjchifbged_Volume0p6 does not exist. Dropping to a shell!

I installed Ubuntu 12.10 on a system that has Windows 7 and Intel rapid start (win swap partition) on it. The hard disk is a fakeraid0, which is understood by the live cd. I wanted a dual boot, so I had a primary /boot partition and the rest of Ubuntu in a LVM. Windows resides in two primary partitions (one 60GB for C: and one 350MB for booting Windows 7)

How do I install ubuntu 12.10 in such a situation? The 12.04 installer seemed to understand my intentions with the LVM and delivered a bootable system.
I cannot choose the "install on LVM" option, as this will destroy my already existing LVM with the win7 swap/hibernation partition. Instead, I chose "something else" and appointed existing partitions (/boot, /, /home, swap) to be used for installation.

My partition scheme is listed below, but bear in mind that this is backup information from when I had 12.04 installed. The scheme used for the 12.10 installation varies slightly, but it's conceptually similar.

Disk /dev/mapper/isw_cjchifbged_Volume0: 256.1 GB, 256066715648 bytes
255 heads, 63 sectors/track, 31131 cylinders, total 500130304 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 32768 bytes / 65536 bytes
Disk identifier: 0xe240c089

                              Device Boot      Start         End      Blocks   Id  System
/dev/mapper/isw_cjchifbged_Volume0p1   *   125831168   126547967      358400    7  HPFS/NTFS/exFAT
/dev/mapper/isw_cjchifbged_Volume0p2       126547968   127062015      257024   83  Linux
/dev/mapper/isw_cjchifbged_Volume0p3            2048   125831167    62914560    7  HPFS/NTFS/exFAT
/dev/mapper/isw_cjchifbged_Volume0p4       127062016   500127743   186532864    f  W95 Ext'd (LBA)
/dev/mapper/isw_cjchifbged_Volume0p5       483315712   500127743     8406016   84  OS/2 hidden C: drive
/dev/mapper/isw_cjchifbged_Volume0p6       127064064   168024063    20480000   83  Linux
/dev/mapper/isw_cjchifbged_Volume0p7       466497536   483313663     8408064   82  Linux swap / Solaris
/dev/mapper/isw_cjchifbged_Volume0p8       168026112   466495487   149234688   83  Linux

Partition table entries are not in disk order

What I tried in order to fix things was the following:
Boot from live CD (actually: usb drive),
Mount /, /boot, /dev, /sys and /proc and chroot into that system (following this guide),
apt-get install lvm2 (which was not installed; following this guide; dpkg-reconfigure lvm2 is automatically triggered)

This did not fix my problem. When I inspected /dev/mapper from that shell (BusyBox built-in shell ash), it was empty.

Since I overwrote my previous Ubuntu 12.04 installation, there was no windows MBR, and thus the grub installer did not create a windows option. To make sure I could boot at least something, I ran the windows recovery tool bootrec.exe /FixMbr. Now I have a totally inaccessible zombie-ubuntu on my disk :P


I figured it out myself:

I just tried again. The way I did it is first using gparted to create my partition scheme, and after that, I use the ubuntu installer and appoint the partitions I want to a specific mount points. Since this is exactly the way I did it the first time around, I don't know what made the installer change it's mind.

Important side-note: If you already have some version of Grub installed, and do not have the default windows MBR, the grub installer apparently does not detect your windows and thus it won't create a boot menu entry for it. So first restore your windows MBR. And eventually, don't forget to choose the right device (in my case a /dev/mapper/isw...Volume0) to write the mbr to.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.