There are other threads related to this question for Ubuntu 12.04, however THEY DO NOT APPLY TO 12.10. This is not a duplicate of another thread if the referenced thread doesn't answer the question asked.

  • 1
    what about installing it from the jockey(Additional Drivers) ?
    – Suhaib
    Oct 22, 2012 at 1:46
  • or this ? askubuntu.com/questions/204129/…
    – Suhaib
    Oct 22, 2012 at 1:50
  • 1
    I just get a "no proprietary drivers are in use" notice. No option to install the drivers. Oct 25, 2012 at 3:37
  • Please consider marking my answer.
    – Bucic
    Jan 6, 2013 at 12:28

4 Answers 4


For the purpose of this question: Catalyst = fglrx = proprietary AMD/ATI display driver

The most problems people are having come from the fact that:
1. Ubuntu has moved to newer driver versions, that don't support some older ATI/AMD chips
2. Ubuntu has moved to newer Xorg versions

No. 1 - 'not supported' errors / Jockey not detecting proprietary drivers valid for installation
No. 2 - some older ATI/AMD Catalyst versions won't install

Which all comes down to:
Your chip is no longer supported by the latest ATI/AMD catalyst display drivers (be it via manual install or from Ubuntu repositories)

Check, what is the latest driver version that supports your chip and then proceed with the installation accordingly.
http://wiki.cchtml.com/index.php/Hardware (may be slightly outdated)
enter your graphic card details here:
use terminal command to display information about your graphics

lspci | grep VGA

If the latest version for you is 12.6 => proceed as per https://askubuntu.com/a/201785/29347

Chips that are indicated 'legacy' (not supported for the latest Catalyst versions):
Try the PPA listed here How to install old AMD Catalyst 12.4 drivers on Ubuntu 12.10? You'll most probably get Catalyst 12.6

Chips that ARE supported in 12.10 / by the latest Catalyst drivers:
The installation should be accomplished as per What is the correct way to install proprietary ATI Catalyst Video Drivers (fglrx) directly from AMD?

  • That's odd, I have a Radeon 4870 which is still one of the better cards available. Oct 26, 2012 at 4:24
  • 1
    @ChrisBauer According to the sources I've just added above your 4000 is 'legacy' already. Gotta love planned obsolescence ;)
    – Bucic
    Oct 26, 2012 at 6:08
  • Wow, thanks for your help. I'll look into this when I have more time. Looks like my next card will be a Nvidia :) Oct 26, 2012 at 19:06

Here is the latest version of Ati Catalyst 12.11 (beta) and 12.10 (stable) that has just been released ,you can find it here : http://www.upubuntu.com/search/label/System hope it will work .

  • Thanks, but both the 12.11 and 12.10 versions are giving me the "Your graphics adapter is not supported by this driver" error. Oct 26, 2012 at 4:33

The latest ATI catalyst for Ubuntu 12.10 I know of is this one:
AMD Catalyst 12,9 driver

First Uninstall the current driver AMD with these commands:

sudo sh /usr/share/ati/fglrx-uninstall.sh 
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx  

Manual installation:

To install AMD Catalyst 12.9 in Ubuntu 12.10/12.04/11.10 run the following commands from the terminal:

sudo apt-get install unzip
cd /tmp && wget -O amd-12.9-9.00-EDG_Direct.zip http://www2.ati.com/drivers/embedded/9.00-120815a-146426C-EDG_Direct.zip
unzip amd-12.9-9.00-EDG_Direct.zip
chmod +x amd-driver-installer-9.00-x86.x86_64.run 
sudo sh amd-driver-installer-9.00-x86.x86_64.run

And then after the installation was finished run this command:

sudo aticonfig --initial -f 

Then reboot.

Note: PPA has not been updated so far, but the driver will be updated soon. To install the driver provided by xorg-edgers, open the terminal and run the following commands:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install fglrx-installer
  • I'm getting one of the errors I get fairly often in my various attempts to install the driver: "Your graphics adapter is not supported by this driver. Installation will not proceed." I've tried googling the error to no avail. Oct 25, 2012 at 4:26
  • I also tried adding the xorg-edgers/ppa repository and installing fglrx-installer, but I don't know what to do after that. Running fglrx-installer at terminal gives a bad command error. Oct 25, 2012 at 4:27

If you would like to update your ATI / AMD Catalyst Proprietary Display Drivers to the latest release, or would like to try the latest AMD Catalyst BETA drivers, have look at :

The Fan Club - Ubuntu AMD Catalyst install

  • The application auto detects your ATI / AMD graphics hardware and selects the best driver options to install.
  • This application downloads, creates DEB packages and installs the latest AMD Catalyst™ Proprietary Display Drivers for Ubuntu 32bit/64bit.
  • You can also install the latest AMD Catalyst™ Proprietary Display BETA Drivers as well as Legacy AMD Catalyst™ Proprietary Display Drivers if your hardware is supported.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .