1

Has anyone tried this external usb sound blaster on ubuntu.
http://us.store.creative.com/Sound-Blaster-XFi-Surround-5.1-Pro/M/B0044DEDCA.htm.

I have bought M-Audio Bx5a deluxe Studio Monitors for my T61. I think the onboard Intel HD sound card will not do any justice to these speakers. So I am looking for an external sound interface. I particularly liked this one as it is not very expensive and it has a volume control (speaker lack a central-front volume knob). Has anyone been able to use this on ubuntu.
Also, if anyone would like to recommend me another option?

1

I use this sound card. It works out of the box (but I cannot test >2.0) in Ubuntu 10.10 (and it is working in Gentoo, Arch). But it doesn't works with Flash (YouTube,..) out of the box (because it uses ALSA instead of Pulseaudio).
It is also even possible somehow to get it work with OSS4 (used in *BSD, Solaris; available for Linux).

1
  • Thanks for answering. I did buy this card and later returned it. The volume knob didnot work for me, even the remote didnot work for me. I then tried to install it on windows 7, first i used default drivers the card worked, it played the songs even flash videos, then i tried to install creative suite ( utility/driver CD), it didnot install. But the volume knob didnot work in both the cases. So my question is does the volume knob and remote works in Ubuntu, as i think this volume control feature is not dependent on driver or utility cd. Jan 10 '11 at 11:21
0

I'm trying to make it work with 5.1 but it's not straightforward. Volume knob doesn't work out of the box either but that's not that important.

2
  • Apiman, please do share your experience in getting it work in ubuntu. My mail concern is the volume knob, as both the speakers have individual set of volume knobs. Having one unified hardware would be good. Jan 24 '11 at 9:26
  • Sorry, I haven't tried to use the volume knob, but I've read somewhere (I can't remember where) that lirc is the daemon to use. For me, sounds works fine now, but I must say I'm not using Ubuntu anymore.
    – aitorpazos
    Jul 9 '11 at 11:27
0

my has arrived today.

On 14.10 with pulse it works out of the box for 2.0 (volume knob not) (sound is awesome). At home I will test it with 5.1 so I will edit this to answer 3 y old question.


I got it working in 5.1, it was weird, first it detected only as 2.0 (pulse) and alsa as 5.1 (aplay -L), so i uninstalled pulse rebooted and i was able to select all posibilities of soundcard in pavucontrol. Then i installed back pulse, indicator-volume rebooted and now everything is detected correctly :-) (using ubuntu 14.10)

Home my answer will help to someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.