Was anybody able to install Citrix Receiver on Ubuntu 12.10?

Both 32 bit and 64 bit deb package fail to install properly.

here is the error message for installing 64 bit package:

sudo dpkg -i icaclient_12.1.0_amd64.deb 
(Reading database ... 139512 files and directories currently installed.)
Preparing to replace icaclient 12.1.0 (using icaclient_12.1.0_amd64.deb) ...
Unpacking replacement icaclient ...
dpkg: dependency problems prevent configuration of icaclient:
 icaclient depends on ia32-libs; however:
  Package ia32-libs is not installed.
 icaclient depends on nspluginwrapper; however:
  Package nspluginwrapper is not installed.
dpkg: error processing icaclient (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

It seems like the problem is that it needs nspluginwrapper and nspluginwrapper needs nspluginviewer and nspluginviewer is not available in Ubuntu 12.10

When I try to install the 32 bit deb package I get the following error message:

sudo dpkg -i icaclient-12.1.0_i386.deb 
dpkg: error processing icaclient-12.1.0_i386.deb (--install):
 package architecture (i386) does not match system (amd64)
Errors were encountered while processing:

Any suggestions?


I had the same problem after a fresh install of Ubuntu 12.10. It seems that you have to install nspluginwrapper first. This can be done with the software center for example. After that the install worked fine.

  • 1
    Hi Rob, are you using 32 or 64 bit Ubuntu? I am not able to install nspluginwrapper. – user99305 Oct 27 '12 at 18:46

The error popping is just about a postinst script failing to detect x64 arch. You can edit the postinstall file and run apt-get install -f to clean error messages.

See this article: CitrixICAClientHowTo - Community Ubuntu Documentation: Citrix ICA Client 12 on Ubuntu 12.04 64-bit

Particulary this excerpt:

Beware - this should be used with caution as it will install with an error. The postinst script exits 2 as it fails to correctly determine the architecture of the system. The ICAClient package will function, but APT will complain that ICAClient is "not fully installed or removed" and you will get errors each time you use a package manager.

This can be fixed by unpacking the deb and editing the regular expression in line 2648 of the postinst script to match x86_64. Then rebuild the deb and it should install without a problem.

Alternatively /var/lib/dpkg/info/icaclient.postinst can be edited after an installation that gives an error and apt-get -f install can be run afterwards.

  • 1
    the error is not related to postinscript. The error is related to failed dependencies. – user99305 Oct 27 '12 at 1:59

icaclient will throw errors that it failed to install when it installed correctly. I installed it just fine using the Ubuntu Software Center, it worked although it still said install failed.


I needed to use a patched installation package, check out this: dpkg reports error on package icaclient

I opened a forum thread on Ubuntu Forums to get more hints and tips to get it work:


The following worked for me on 12.10 (32 bit). It's mostly from http://ubuntuforums.org/showthread.php?t=1645173&page=3

  1. sudo apt-get install nspluginwrapper

  2. Click to download from http://www.citrix.com/downloads/citrix-receiver/receivers-by-platform/receiver-for-linux-121.html and then install automatically using Ubuntu Software Center

  3. Create new file /usr/share/applications/wfica.desktop

    [Desktop Entry]
    Name=Citrix ICA client
    GenericName=Citrix ICA Client
    Comment=Citrix nFuse session file
  4. Create new file /usr/share/mime/packages/ica.xml

    <?xml version="1.0" encoding="utf-8"?>
    <mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
    <mime-type type="application/x-ica">
    <comment>Citrix ICA launcher</comment>
    <glob pattern="*.ica"/>
  5. sudo update-desktop-database && sudo update-mime-database /usr/share/mime

  6. sudo gedit /etc/gnome/defaults.listand add the line: application/x-ica=wfica.desktop

  7. Run the following from the command line:

    sudo xdg-mime install --novendor /usr/share/mime/packages/ica.xml
    sudo xdg-mime default wfica.desktop application/x-ica

For me, this now allows citrix to work from both Chromium and Firefox on Ubuntu 12.10.

Not the answer you're looking for? Browse other questions tagged or ask your own question.