This is the message I get when I try to rip a cd from any player. I usually use the stock Rhythmbox but have tried others to no avail. I have just updated to 12.10 from 12.04 and I had no problems in 12.04. I have read the other posts and have switched to the Main Server in the Software Sources menu. I have installed Ubuntu Restricted Extras. Nothing seems to help. I would appreciate any help.

"Python (v2.7) requires to install plugins to create media files of the following type: Vorbis encoder"


  • And i have used the command line to install python. Still didn't help. – LibraryGeekAdam Oct 21 '12 at 20:13

Same thing happened to me, but I finally get some clues in this thread.

Turns out that problems are caused by the config file:

sudo gvim /usr/share/rhythmbox/rhythmbox.gep 

Delete or comment the "preset" line as follow

name = oggvorbis
description = Ogg Vorbis
format = application/ogg
type = container

parent = oggvorbis
type = audio

#preset = rhythmbox-custom-settings

format = audio/x-vorbis
presence = 1

and, voila, restart your Rhythmbox, problem solved.

  • 2
    works but you have to comment several present lines – don.joey Jan 2 '13 at 15:59

This answer from ubuntu forum solve the problem esasily:


The "Install additional software required to use this format" message seen for vorbis encoding is a bug. All needed libraries are installed by default, as is vorbis encoding in RB. (if you went ahead it would have used the 'ubuntu default'

To get the message to disappear you have to pick ' Custom Setting" & set a quality value, then close & open RB (Default is gnome default of 3 Ubuntu is a quality of 6 or you can set as desired, higher the better quality


I have gotten the same error on 12.10 and have not found a fix, but have a workaround. Install Sound Juicer and it will extract with no error, then open Rhythmbox and it will import the information after a couple of seconds. Not perfect, but it works for me.

  • That's what I started to do but 12.10 just had too many bugs and issues on my Dell Latitude and I ultimately unistalled it and put 12.04 back on. Works much better now :) – LibraryGeekAdam Nov 27 '12 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.