3

Recently I tried installing Teamviewer7 on my Ubuntu 12.04. I tried downloading the deb which due to some reason never did finish its download (stopped at ~10MB/17MB).

Expectedly, installing the same gave unmet dependencies. I followed instructions given

sudo dpkg -i teamviewer_linux.deb
sudo apt-get install -f

These are to my memory the only changes I made to the system. Following this, my apt-get or dpkg seem to be broken.

Following is a sample call which returns errors in subprocesses. (specially not: dpkg and install-info)

$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 34 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up install-info (4.13a.dfsg.1-8ubuntu2) ...
/var/lib/dpkg/info/install-info.postinst: 32: /var/lib/dpkg/info/install-info.postinst: update-info-dir: not found
dpkg: error processing install-info (--configure):
 subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also, my Synaptic Package Manager and Google Chrome (if that's of any consequence) are not opening at all while Firefox et al seems to be working in order.

I tried out many things. A few suggestions included replacing /var/lib/dpkg/status file with a copy from a working version. This I believe might correct the broken dependencies. However I do not have a working copy accessible at the moment (not unless I create a bootable).

I really need some way to roll back the system to the previous state (backup doesn't work either).

Any help is appreciated. Thanks!

2 Answers 2

3

After my failed attempt to install Teamviewer7, my system was not just missing bash, but when I attempted to manually install bash from a manually downloaded deb package, I got an error about a missing dependency: base-files.

I used the following command:

sudo apt-get install base-files

This install completed successfully. Afterwards, I closed the terminal and reopened it and the various bash features (including the history) came back.

3

Turns out that the process had removed Bash from the system. If you have the same problem, follow the instructions here.

The basic procedure is as follows:

Go to the directory:

cd /var/cache/apt/archives

Find the corresponding deb for bash. On 12.04, it may look like

bash_4.2-2ubuntu2_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.