I have noticed the trend that ubuntu is getting increasingly slower with each release. It used to be much faster than windows, but now it is really much slower.

I have an Asus G74Sx with an i7 processor, 8Gb of RAM, and an Nvidia Geforce GTX 560M graphics card. I am currently using ubuntu 12.10, but will probably be going back to 12.04. Ubuntu is running as the native operating system. There is really no reason for terminal to take more than 25 seconds to open. I love all of the stuff behind ubuntu, what it stands for and everything, but I need to at least be able to open gedit without waiting 3 minutes for it to open.

Sorry if this sounds like a rant. What can I do to get ubuntu running smoothly?

  • 2
    This behaviour is clearly abnormal, it's a little short sighted to view this is being the default performance of Ubuntu. I have a laptop with similar specs, and it is lightning fast. Do you have the right graphics drivers installed on your system? – Dominic Jordan Hasford Oct 21 '12 at 5:12
  • I have used ubuntu since 10.04. I know that it can be lighting fast which is why I am concerned when it is not. Especially on a system that is as powerful as the one I am using it on. Anyway, I used the methods from: askubuntu.com/questions/203051/… – Evan Oct 21 '12 at 6:17
  • I thought it was graphics related, I had a similar issue. – Dominic Jordan Hasford Oct 21 '12 at 7:13

The behaviour doesn't seem right to me anyway.

To identify the bottleneck, you can:

  1. install bootchart http://www.bootchart.org (boot process)
  2. use htop/iotop/vmstat to identify system performance bottleneck
  3. check your HDD and see if it has problems
  4. Disable unnecessary services
  5. Search and see if you hit any Ubuntu 12.10 bugs (I think all Ubuntu users have been hit by bugs after each upgrade lol)

BTW: Why gedit? Sublime Text 2 (you don't have to register) is cool;-)

  • Okay, on htop, there are four entries for each process. So, four compiz, four lightdm, etc... They don't always have the same levels, but for compiz, all of them are consistently running around 10% memory levels, and are frequently at the top of my CPU%. Other than looking at the data from htop, the system is completely idle. If I go to just command line and kill compiz, the load drops considerably and commands run pretty fast. Sadly, compiz is important. – Evan Oct 21 '12 at 6:11
  • Try using a different Nvidia drive, I suspect it is a driver problem. – Terry Wang Oct 23 '12 at 22:36
  • I switched over to gnome and everything is lightning fast again. Thanks though. – Evan Oct 24 '12 at 2:06

Try the Ubuntu 12.10 Live DVD (or boot from an USB stick) and check whether this changes the poor performance. If it fixes the performance problems, a clean install of Ubuntu 12.10 could be a solution.

  • Oh man, from "try ubuntu without installing", it doesn't even load the interface. I actually did originally do a clean install of ubuntu 12.10 – Evan Oct 21 '12 at 13:50

Have you enabled the proprietary drivers for your nvidia card, this can make a huge difference. My laptop is a i5 with built in Intel and its running as fast with Unity smoother than 12.04.

  • I installed the drivers from the vendor. The ones that come with ubuntu only cause more issues with compiz. – Evan Oct 21 '12 at 13:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.