0

I have a question about the grub2 implantation in Ubuntu 12.04.

I have a dual boot system with windows 7, Ubuntu as the primary OS. When I have #GRUB_DISABLE_OS_PROBER=true in my /etc/default file, grub boots to Ubuntu without showing a menu, and shows the menu when I hold down shift, however, the menu does NOT have my Windows 7 boot drive as an option.

If I have #GRUB_DISABLE_OS_PROBER=false, Windows 7 shows up in the grub menu, but the grub menu is always shown on system start, even though GRUB_HIDDEN_TIMEOUT=0 and shift is not held.

Is there a way to have the OS prober turned on, but only have the grub menu shown when shift is held down?

  • I was thinking about manually adding the Windows 7 entry, and leaving the OS Prober turned off. Assuming this gets me the right behavior and a Windows 7 Entry it would be fine for all intents and purposes, but it WOULD be nice to leave the prober turned on. – Bret Oct 21 '12 at 4:17
1

Only the following two lines should be relevant:

GRUB_HIDDEN_TIMEOUT=3
GRUB_HIDDEN_TIMEOUT_QUIET=true

The first defines the timeout to press the Shift key. Set it to something other then zero, for example 3.

The second tells Grub not to show the menu by default.

Both lines should be uncommented.

Dont forget to run sudo update-grub at the end.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.