I was a little surprised to discover that in LibreOffice (3.5.4.2), the spell check doesn't actually work. I was surprised since spell checkers have been around since....80's? Not a difficult thing.

I am running Ubuntu 12.04, on a relatively new install. I haven't done anything to my dictionaries or language files.

Under tools>options>languages> writing aids, I have the option selected to check as I type and to use the English dictionaries.

However, I get no errors when I type spelling mistakes on purpose, and when I run the checker it just says the spell check has completed and closes the window.

Is this a bug with Libre? or have I done something wrong?

  • Do you have auto spell-check enabled. It is located under the 'Window' Drop-down menu. – Ryan Dec 5 '12 at 17:13
  • 4
    Ridiculous that is doesn't work out of the box. – Karl Morrison Apr 19 '15 at 22:57
  • true, this surely IS "writing aids". – Blauhirn Dec 5 '16 at 17:24
up vote 34 down vote accepted

A quick fix for the current document (assuming English text) is Tools - Language - For All Text - English (USA).

I think the permanent fix is to make sure that the default language used for documents is supported by an installed dictionary. This solution has been documented by "idiota" on LibreOffice's questions forum:

"The problem is fixed by clicking Tools/Options/Language Settings/Languages. It allows dozens of flavours of English, BUT spelling is disabled for all the ones that don't have the little blue tick ABC icon beside them."

http://ask.libreoffice.org/question/1678/spell-checking-not-working-in-v342/

  • 4
    Hoisted on my own sense of patriotism! I was set on English (Canadian), which doesn't have a dictionary apparently. English US works fine. Thanks. – Michael Oct 22 '12 at 1:16
  • 1
    This was it! I wouldn't have chosen Canadian had I known that it would disable spellcheck. – revnoah Aug 27 '13 at 21:26
  • Indeed, the comment on that site of sudo apt-get install myspell-en-gb fixed it for me. – sil May 12 '17 at 17:18

When choosing your language do you see the check besides it?enter image description here

If not then open up "Language Support" and click on "Install / Remove Languages..." and install the language you want and close LibreOffice and try again.

  • 3
    Where is "language support?" – Rabbit Oct 20 '15 at 18:01
  • 3
    You should find it by searching "Language Support" in the Unity Dash, otherwise it's in the "System Settings". You could also open it via terminal by writing "gnome-language-selector" and pressing enter. – Jeggy Oct 20 '15 at 18:38
  • 1
    yeah, "Language Support" is not a LibreOffice feature/menu, but coming from Ubuntu itself. – mnagel Apr 1 '16 at 9:06
  • This seems like terrible usability design. If none of the languages had any checkmarks, I don’t see how anyone would expect that they would need something like checkmarks next to them. – Guildenstern Aug 2 '17 at 11:43

To install the spell check packages for English and USA the terminal commands are:

sudo apt update
sudo apt install myspell-en-gb myspell-en-us

Notes:

  • If you already have installed hunspell-en-gb then you have to remove it to install myspell-en-gb.
  • If you already have installed hunspell-en-us then you have to remove it to install myspell-en-us.
  • 1
    your link may answer the question precisely but as per rules of AU you should have to mention either full or part of the answer. – rɑːdʒɑ Aug 19 '13 at 12:14
  • Regarding the note, if you have hunspell installed then you don't need to install myspell anyway... – OJFord Aug 29 '16 at 21:38
  • myspell-en-us is no longer available for me on Ubuntu 17.10 – Patrick Feb 13 at 0:11

Install the following:

sudo apt-get install myspell-en-us

Now restart the office suite to make the spell check work. Hope this helps

  • +1 this is the only answer that worked in my case – user000001 Jan 3 '17 at 18:09

In my case the spell-check option to enable my language of choice was not present.

The dictionaries were installed so the problem was with the office program.

This was remedied by the following :

  1. killall soffice.bin

  2. rm -r .config/libreoffice/

  3. Start LibreOffice & go to Tools->Options-> Language Settings -> Default language for documents: English UK (now with spell check icon)

PS: For English UK I have libreoffice-l10n-en-gb and myspell-en-gb installed.

  • Worked for me. I had an old config folder from previous installations. – Morlock Oct 17 '17 at 13:48

Go to -> tools-> options-> languages-> western. Then set the western language as English usa as it is enabled with spell checking.

If you've chosen anything other than English (USA), it'll likely not have spellcheck available.

That's the A with green dots seen here:

enter image description here

If you need a GB, AU, CA or ZA English variant, install the English Dictionaries extension.

protected by Community Sep 8 '15 at 5:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.