i tried to setup my printer in Ubuntu 10.10. I had to use special guide to install because Canon used libcupsys2 in its packages and ubuntu expects libscupsys i followed this guide in reference to this advice.

The first problem was this one (the ubuntu "add printer dialog asked for root credentials". The suggested workarout in Launchpad to create a root password worked.

Now i added the printer. It's available for printing. Then i got an error message "cups insecure filter" which prevented me from printing. That could be solved by setting the need root rights in the /usr/lib/cups/filter/ directory. The error message disappeared after restarting cups service. Now it should work but it doesn't.

The main problem is now, the printer seems to be proper setup but when i try to print a document, the printer icon appears for short time in gnomepanel. There's a printing job in Queue which got completed, but the printer doesn't print.

I attached the Debuglog provided by printer error control, had to upload to another site, since it was to big in the question body here. Perhaps someone can identify the problem with it?

Note: i know that it once worked fine with an older release of Ubuntu, but not sure which version this was.


Ok, i tried several ways to get the printer running.

One way was to install the libcupsys transitional package, it let me install the debian drivers version 3.0 for mp540. - the printer didn't work

The other way was to customize the packages to work with libcupsys as described in the linked guide above - this also wasn't succesful - the printer didn't work.

The last idea, since the printer of the mp series seems to be very similar, was to try the drivers for the mp550 instead. the debian version was 3.2 (from 2010) as the mp540 debian drivers were 3.0 (from 2008). - They work perfectly. Same advice for the scan drivers. i used the linux scangear drivers 1.4 for mp550 (from 2010) and they work as a charme. So perhaps, if someone has the same problem use this drivers and it should work. Perhaps you could also need to install the libcupsys2_1.3.9-17ubuntu3.9_all.deb transitional package, i tested this not extra since i had it installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.