Just updated to quantal 12.10, and Unity works fine, but and I can't get gnome-shell to work :(

Some symptoms:

  • when using gdm as the default, it decided to display everything in chinese. When attempting to log in, it accepts the password, and then seems to crash when trying to load my desktop, and seems to restart gdm and send me back to the login screen
  • when switching to lightdm as the window manager, it gets a little further (and in english), bringing up a desktop, but a broken one -- the propeller key doesn't bring up a menu, there's no menubar or notifactions area. i can do a few things, like bring up a terminal with ctrl+alt+t, and launch eg firefox from there, but not much else.

I have tried uninstalling gnome-shell, deleting /etc/gdm, and reinstalling

Any other suggestions? Which log files to look at for example?

  • 1
    Did you try purging gnome-shell then reinstalling? Uninstalling something may leave corrupted configuration files behind; when you install it again these configuration files themselves are used once more and they would corrupt the shell. However, purging removes everything (and if you're purging a PPA it would even return the original software back). So try purging gnome-shell and all its related apps then reinstall it. – Vagrant232 Oct 20 '12 at 13:11
  • thanks, good suggestion. not fixed, but gdm is sligthly healthier - i can use it to log into a unity session, but not to log into a gnome-shell session. same problem, no windows-key, no activities. – hwjp Oct 20 '12 at 13:27

OK, I think I've fixed it. Cf this bug report, which I submitted: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1069104

It looks like the problem was that a program called policykit-1-gnome wasn't installed. I found this in the logs:

gnome-session[3819]: WARNING: Failed to start app: Unable to start application:
Failed to execute child process "/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1" (No such file or directory)

And the fix was just to

sudo apt-get install policykit-1-gnome

Then restart.

  • Was already in the newest version on my system – krlmlr Oct 24 '12 at 12:34

Reinstalling gnome-session, gnome-session-fallback fixed the issue for me.


I'm not very experienced in this, but I have some ideas:

1: Try installing the extra gnome packages (gnome extras, etc)

2: If Unity works as it should, then I'm guessing that probably your GDM xsession of gnome is not there, or something is wrong with it.

Usually GDM sessions are saved in: /usr/share/xsessions

You can check if its there with:

ls -l /usr/share/xsessions/

You should see something like: "-rw-r--r-- 1 root root 6747 Jun 10 03:21 gnome.desktop".

If its not there, then you might have to add it manually. You can edit or view the gnome.desktop file as a normal text file.

nano /usr/share/xsessions/gnome.desktop

In my case I have at the end of the file:


This file is loaded by the GDM / lightdm / lxdm / kdm, and when you select it, it will load the "gnome-session". Good luck!

  • 1
    interesting. I do have a file there, but it's set up a little differently - Exec=gnome-session --session=gnome and TryExec=gnome-shell. that all looks fairly sensible tho? – hwjp Oct 20 '12 at 13:32
  • hmm... looks... good enough... either way, you could try adding a custom entry: cd /usr/share/xsessions wget with this you will download my gnome session, it simply has "gnome-session" as I told you then try logging out, and check if its there (there might be 2 gnome sessions, try them both) – ubunchu Oct 20 '12 at 13:46
  • nope, didnt help. Any idea which log files i should be looking at for debug? – hwjp Oct 20 '12 at 14:03
  • nope, i don't know about that. Though you could try to create a custom DE. more info here: goo.gl/etKB8 (and instead custom commands, you can use "gnome-session" instead) – ubunchu Oct 20 '12 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.