I had 12.04 with my dual boot system. Yesterday I downloaded Ubuntu 12.10 make bootable USB and choose Upgrade option in Installer. After installation Grub failed to boot my machine. I tried following to fix grub bootloder . Same problem I fixed with Ubuntu 12.04 using live USB but this solution not work for Ubuntu 12.10. Now coming at exactly where this solution goes fail.

I followed this steps after booting Live USB and opening terminal.

1) sudo fdisk -l to see where Linux is installed

2) sudo mount /dev/sda9 /mnt where sda9 is my linux partition

3) sudo mount /dev/sda9 /mnt/boot

4) sudo mount --bind /dev /mnt/dev

5) sudo chroot /mnt (No problems with this steps done perfectly)

6) grub-install /dev/sda when I type command I got error that

source_dir doesn't exist Please specify --target or --directory

How can I solve this?

  • Did you try the Boot-Repair ?
    – NickTux
    Oct 20, 2012 at 4:54
  • Oh , just answered to your question.. hah. Can you provide the link with boot-info ?
    – NickTux
    Oct 20, 2012 at 4:57
  • I worked with terminal so didn't get screenshot.
    – KK Patel
    Oct 20, 2012 at 5:01
  • Boot-Repair is not a CLI program is a GUI program. Are sure you ran it ? Boot again from LiveCD-USB and run again boot-repair. It will create a boot-info link with useful informations. Edit your question and add this link.
    – NickTux
    Oct 20, 2012 at 5:06
  • I want to repair with just with Live USB. In 12.04 I had fixed problem with this but problem occurs with 12.10 Only
    – KK Patel
    Oct 20, 2012 at 5:08

2 Answers 2


For general boot problems (even specific problems UEFI - GPT) with grub-boot-loader you can use the Boot-Repair program from a LiveCD-USB of Ubuntu.


Boot repair disk is the best solution in boot problems, I ever found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.