I've used Ubuntu in the past (set up as web server, etc over in Iraq), so I'm not a 100% Linux Noob, however, I'm running into a brick wall here.

I've got a machine I built when I got back to the US earlier this year, running Windows 7 Ultimate on it, and I've now got some free time and would like to transition over to Ubuntu full time.

I've searched around in the forums, and there seems to be an issue with the nVidia graphics cards, so I've tried going to the EVGA site to see if I could find a new BIOS update for it and had no luck, so I'm back searching the forums here again and decided to just go ahead and post my question. My apologies if this is covered in another post and I was just unable to find it. I've found a few 'similar' posts, but nothing as bad as my issue.

With the history aside, here is the actual detailed issue:

I purchased a new SSD (Intel 520 SSD), arrived today, and I disconnect my old Windows 7 SSD. I had pre downloaded the ubuntu-12.10-desktop-amd64 earlier today and burned it to DVD.

Upon inserting the Live CD into the computer and booting up, everything was fine up to the 'Run From Live CD' or 'Install Ubuntu Now' buttons. As I was sure I wanted to go ahead and make the switch, I selected the 'Install Now' from the right hand side.

CD Spins up, black window pops up, and then the errors started:

date/time GPU Lockup date/time Failed to idle channel 1 date/time PFIFO - playlist update failed date/time Failed to idle channel 2 date/time PFIFO - playlist update failed

Thinking it might correct itself, I let it run and it would swap over to a GUI Screen that was locked up with major blurring/etc, then back to the command line with the errors. Eventually it said something along the lines of 'unknown status' and switched back to the GUI and froze.

So, that's when I tried to see if I could find a BIOS upgrade for the nVidia GTX580 cards, and had no luck. So I thought, why not try to just run it from the Live CD and see if I can at least get a look at it, maybe if I could get it running try to do some sort of install from there and fix the driver issue.

I rebooted, brought up the Live CD, and this time chose the left option / run from the CD. It brought me all the way in to the desktop, I saw my drives, the other icons, could move the mouse, etc for about 30 seconds and then it locked up completely. I've tried this a couple of times and get the same results every time.


Intel i7-3930K CPU @ 3.2GHz (12 CPUs) / MSI MS-7760 Motherboard / 32GB RAM / 2 x EVGA (nVidia) GeForce GTX 580 (4GB Ram each)

So the question is:

Is there any way to install 12.10 if you can't even get the Live CD to run (for more than 30 seconds)?

My current hardware configuration is both of the GTX 580 cards have an SLI jumper on them, and I have 2 monitors on each card. (Ubuntu info obviously only shows on the main monitor from the failed installation and the attempt at running the Live CD).

Perhaps opening the machine back up and removing the SLI Jumper and removing the other 3 monitors (so it only would have 1 video card with one monitor on it) would actually allow me to get 12.10 installed, then I could work on an nVidia Video Driver fix for the GTX 580, and then possibly hook up the other video card and monitors? Or is this something that they are currently aware of and may update with a future release in the next few days/weeks?

Any thoughts or suggestions would be greatly appreciated, as I can't even try to fix the issue (assuming it is the nVidia drivers) if I can't even get it to install at all.

  • Your "Perhaps" would be my answer to your question. Try it and let us know if worked. – NickTux Oct 20 '12 at 4:52
  • Well, 3 hours later and I'm ready to give up for the night. Here is the latest update for troubleshooting attempts (and no, I saw absolutely no changes with the 12.10 64 Bit): – user99056 Oct 20 '12 at 8:18
  • 1. Removed 3 of the 4 monitors (left one on HDMI) -no 2. Removed the SLI Connector (left one on HDMI) -no 3. Switched monitor to DVI-1 -no 4. Switched monitor to DVI-2 -no 5. Removed the '2nd' video card from PCIE 3, left primary monitor on DVI-1 on first Video Card (PCIE 1) -no 6. Put '2nd' video card back in PCIE 3, removed '1st' video card from PCIE 1, reboot w/ monitor on all 3 (2 DVI and 1 HDMI) ports -no – user99056 Oct 20 '12 at 8:28
  • At this point, I'm willing to buy some new high end nVidia cards that are -known- to work 100% with Ubuntu if I am not able to come up with any fancy tricks (like maybe installing it to the SSD via a laptop, then putting it back in the tower or something, not sure if that is even possible w/ Ubuntu). Any thoughts on what I might try (other than replacing the video cards)? – user99056 Oct 20 '12 at 8:31
  • Oh, and after I at could not do anything else with the hardware configuration, I downloaded ubuntu-12.04.1-desktop-amd64.iso from the Ubuntu website. Burned it, verified it runs, did a reboot with it in and all I end up with (after a brief flash of the Ubuntu Splash) is a black screen with a flashing underscore cursor. Even updated the MSI MoBo BIOS too, on the off chance it was somehow affecting the process... – user99056 Oct 20 '12 at 8:38

I managed to get my desktop running with a Nvidia Geforce GTX 580. I installed Ubuntu 12.04 via the alternative installer, which can be found here.

Before finishing the installation, i installed the nvidia graphics drivers. To do this, open a shell with ALT+F2, then run the command "chroot /target" and then run "apt-get install nvidia-current". Press CTRL+D and then ALT+F1 to exit the shell. Then finish the installation.

After installing, it was necessary to add the option 'nomodeset' in grub.

Credit for the alternative installer trick goes to joelalmeidaptg.

EDIT: Ubuntu 13.04 does not suffer as hard. Nomodeset is needed for installing, but afterwards it is able to boot, albeit with poor resolution. It is then possible to install the nvidia-current package and it works great afterwards. I have submitted a bug report to this issue.


Perhaps create a live USB disk, boot it on a machine with a different card, install the proprietary Nvidia drivers, then see if it'll run on your 580?


I had same problem. Boot in NOMODESET mode to get installer up. To get nomodeset, wait for the first dark grey boot screen with the keyboard=little man icon and press any key to get the basic menu. Then press F6, use the arrow keys to go down, select nomodeset, press Space (so there is an X by it) and then press ESC.

Now you can do your install with no errors.

I had the same issues with GTX580 in the previous version as well. Seems like a basic thing Canonical could do, to have properly working graphics drivers for major chipsets. Durh.

Will post again about fixing the driver once installer is done. (I'm installing now)

  • Ubuntu can't install the 'drivers' because the code is proprietary. No-one can release useful open source drivers because the manufacturers will not release their code as open source for people to look at. Write to the manufacturers and tell them you are unhappy with the level of support they provide for their cards. – fabricator4 Jan 5 '13 at 20:31

May I suggest that you download and install the latest drivers from: http://www.nvidia.com/object/linux-display-amd64-319.32-driver.html

These are much developed from the old driver on the Ubuntu site, and overcame all my issues with in stalling a GTX650 card. Thanks to Nvidia for the ongoing development.


Hm, - GTX 580 has CUDA - Technology ( but not optimus, so bumblebee is necessary or not necessary ? ):

nvidia has since May 2013 special driver-package for CUDA-Technology. Not sure if you need then to add bumblebee here, but you can download this CUDA-package for Linux here:


I think this package has been mainly built for CUDA-Technology ( not only for Optimus ).

Am not sure, but this package might be then THE solution. I don't know too if GTX 580 belongs to "hybrid-cards" ?

I solved this thing with CUDA-specific installation like here ( this worked in my case with CUDA-Optimus-Card of nvidia GT 540M properly ):


I don't know if this answer helps. Drivers for nvidia-cards are case-sensitive and it depends on your hardware. If this answer helps not, it is not my fault.

  • I don't have the hardware to test, so it's on people that do to vote the best answers up. – RobotHumans Jul 5 '13 at 0:16

Got this working with just about the same configuration. I had to install ubuntu on another machine and install the nvidia drivers while it was in the other machine. Switched the ssd over to this machine and it worked "mostly." It doesn't do full screen resolution yet, but i might still have the wrong driver.

best of luck -Anthony

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.