I upgraded to Quantal recently, and Minecraft seems to not want to run in fullscreen. When I go to fullscreen it, the screen will go black for a second, as if it was about to go fullscreen normally, but then it just restores back into its window. So far I have tried:

  • using different JREs (I've tried openjdk 6 and 7, as well as oracle7). Oracle's jre wouldn't even run Minecraft (I just got a black screen after logging in)

  • switching graphics drivers (tried nvidia-current, nvidia-current-updates, and xserver-xorg-video-nouveau)

  • updating minecraft bin files

  • updating lwjgl libraries separately from the lwjgl site

None of this seemed to work at all.

I am running Minecraft with the command java -Xmx1024M -Xms512M -cp minecraft.jar net.minecraft.LauncherFrame

Graphics card is GeForce 9500 GS/PCIe/SSE2.

Everything was working fine a few days ago when I was on 12.04.


This happens to me too. But, at random, when I press F11, it goes full screen. So I keep pressing F11 until it stays full screen. Sometimes it takes up to 10 tries.

Try using Magic Launcher

  • For me it took like 30 tries – gustavwiz Aug 9 '15 at 19:03

protected by Community Jan 14 '14 at 23:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.