My sound has disappeared on my Ubuntu Lucid machine. It was there yesterday. I think we took a power cycle overnight and so my pc had rebooted this morning. After compiling PJSUA (the pjsip commandline sip client) and installing it, I tried to run it. No sound.

$ lsmod | grep snd

no output.

$ alsamixer
No such file or directory,

Just because you need to know, I tried innstalling oss on this machine. Did n't get it working and TTHOUGHT i'd remove it. But some parts are still there.

I have googled for hours and have tried a dozen fixes. None have worked.

$ sudo lshw
        *-multimedia UNCLAIMED
         description: Audio device
         product: 631xESB/632xESB High Definition Audio Controller
         vendor: Intel Corporation
         physical id: 1b
         bus info: pci@0000:00:1b.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress bus_master cap_list
         configuration: latency=0
         resources: memory:fcffc000-fcffffff

$ lspci
      00:1b.0 Audio device: Intel Corporation 631xESB/632xESB High Definition Audio Controller (rev 09)

$ sudo apt-get remove alsa-utils
$ sudo apt-get install alsa-utils

$ sudo apt-get remove alsa-base
$ sudo apt-get install alsa-base

$ sudo apt-get remove pulseaudio

$ sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
$ sudo apt-get update
$ sudo apt-get install linux-alsa-driver-modules-$(uname -r)

$ sudo echo options snd-hda-intel model=generic >> /etc/modprobe.d/alsa-base.conf
$ sudo echo snd-hda-intel >> /etc/modules

and probably others I've forgotten.

Root also does not see the soundcards. Of course this is Ubuntu so I can't just login from scratch as root.

I read a suggestion that I might have accidentally blacklisted the snd modules, but I'm not sure which blacklist that'd be in and how to un-blacklist them.

Any help? Anyone?

  • What happens when you run modprobe snd-hda-intel?
    – CL.
    Oct 20, 2012 at 8:40
  • $ modprobe snd-hda-intel FATAL: Module snd_hda_intel not found. Does not sound promising does it?
    – Wes Miller
    Oct 22, 2012 at 11:19
  • Additional news: I rebooted and GRUB-selected my previous kernel. Sound works just fine. "modprobe snd-hda-intel" returns nothing. Knowing this, should I just apt-get a new kernel upgrade and clobber the previous kernel upgrade? Perhaps I should delete the last kernel upgrade? By deleting what?
    – Wes Miller
    Oct 22, 2012 at 11:47

1 Answer 1


The sound driver is not included in your kernel, or not installed, or got deleted by another sound system.

(Re)installing the kernel should help.

  • Should I remove the latest kernel (2.6.32-44-generic) before reinstalling? Or just install over it? I am running kernel (latest - 1), (2.6.32-43-generic). All I need to do is to delete the "2.6.32-44" files in /root and do a grub-update, right?
    – Wes Miller
    Oct 22, 2012 at 15:01
  • The install should detect missing files.
    – CL.
    Oct 22, 2012 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .