After my upgrade to 12.10, DNS resolution seems to fail for both local and external addresses. I can successfully ping local and external IP addresses (google.com, at least), but pinging DNS names immediately returns ping: unknown host <hostname>. Connection Information seems to list the correct DNS servers (which I can ping successfully), and changing to Google Public DNS produces similar results. What should I fuss with to try to fix this?


Change to in /etc/resolv.conf

  • It looks like that worked. I was under the impression resolv.conf is generated automatically. This edit isn't going to get wiped out some day, is it? – fourwood Oct 19 '12 at 21:13
  • That is going to get wiped out on reboot. – tgm4883 Oct 21 '12 at 16:34
  • Yeah not a good solution. – bkerensa Oct 22 '12 at 9:10
  • dpkg-reconfigure bind9-host reboot. – Brandon Bertelsen Oct 24 '12 at 3:05
  • If you have resolvconf installed then you should not edit /etc/resolv.conf, and if you do edit /etc/resolv.conf your edits will get overwritten. But if you have resolvconf installed then you don't have the problem in the first place, because NetworkManager registers the correct address,, with resolvconf which writes it into resolv.conf. – jdthood Nov 1 '12 at 13:37

Looks like this is a known issue:

Launchpad bug#1051348

The instructions there worked for me


In a terminal, run

sudo apt-get install resolvconf # in case it got removed
sudo dpkg-reconfigure resolvconf # to restore the symlink at /etc/resolv.conf

then reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.