I have problem with nvidia graphics driver opensource and proprietary ! Can't change resolution on 3d games and there's a bug there are no kernel sources installed and thus jockey can't install proprietary drivers.

I can't change resolution while on games fullscreen. I tried to install proprietary driver and i couldn't plus i couldn't login to ubuntu it showed only the desktop photo no dash no nothing. -tried to install kernel sources and blacklist+remove Nouveau drivers and then installed the proprietary drivers i hope succesfully. -The problem is the same i can't change resolution on 3d games while on fullscreen.

I've installed the sources and be able to install the proprietary nvidia drivers but the problem remains, look what i got in the output of a 3d game exited while i tried to change resolution:

X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 150 (XFree86-VidModeExtension) Minor opcode of failed request: 10 (XF86VidModeSwitchToMode) Value in failed request: 0x25b Serial number of failed request: 497 Current serial number in output stream: 499

I'm giving you more details about my system: i have an nvidia geforce gts 250 , 3,4 ghz quadcore amd phenom2 , 8gbytes of ram.

The output of: sudo lshw -C display; lsb_release -a; uname -a

Is the following:

*-display description: VGA compatible controller

   product: G92 [GeForce GTS 250]

   vendor: NVIDIA Corporation

   physical id: 0

   bus info: pci@0000:01:00.0
   version: a2

   width: 64 bits

   clock: 33MHz

   capabilities: pm msi pciexpress vga_controller bus_master cap_list rom

   configuration: driver=nvidia latency=0

   resources: irq:18 memory:fa000000-faffffff memory:d0000000-dfffffff 

memory:f8000000-f9ffffff ioport:ef00(size=128) memory:fb000000-fb01ffff

No LSB modules are available.

Distributor ID: Ubuntu

Description: Ubuntu 12.10

Release: 12.10

Codename: quantal

Linux darkpc 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64

x86_64 GNU/Linux

I like ubuntu's style and user interface but i hate the bad quality of work they do.

  • I've got similar problem. Nouveau drivers works ok, but when I switch to proprietary, 3D rendering doesn't work completely (including compiz = unity), and I can't change resolution - there's 1024x768 or less, when I have 1920x1080 monitor... – m4tx Oct 21 '12 at 11:18

To install the latest nvidia drivers (304.60 to the moment) on a fresh install of ubuntu 12.10 64 bits follow these steps.

  1. Install the package linux-headers-3.5.0-17-generic *
  2. Download the driver according to your card model and save it at /home/user/
  3. Give it execution permission.
  4. Open a terminal an type: sudo stop lightdm
  5. Press Ctrl + Alt + F1
  6. Login as root
  7. Execute ./NVIDIA...name-of- your-driver-.run in the directory where you saved the driver .
  8. Follow the instructons... the installation it's going to fail, this is cause the nouveau driver is running and it won't let the nvidia driver to get installed, (don't worry about this, at this point the nvidia driver installer will put the nouveau driver in a blacklist file to prevent it from loading the next time you boot your system)
  9. Reboot your system an repeat steps 4-7, This time the installation should be fine and the nvidia driver will be correctly installed.
  10. Re-reboot your system or type sudo lightdm start

    *This may vary depending if you have installed new kernel updates. In that case I suggest to start from step 2, follow instructions until a error message appear saying that the path to the kernel headers can't be found and that you have to install the missing package (in my case linux-headers-3.5.0-17-generic)

Para instalar los últimos drivers de nvidia (304.60 al momento) en un ubuntu 12.10 64 bits recién instalado, sigue estos pasos.

  1. Instala el paquete linux-headers-3.5.0-17-generic *
  2. Descarga el driver que corresponda con tu modelo de tarjeta y guárdalo en /home/user/
  3. Dale permisos de ejecución.
  4. Abre un terminal y escribe: sudo stop lightdm
  5. Presiona Ctrl + Alt + F1
  6. Accede como root
  7. Ejecuta ./NVIDIA...name-of- your-driver-.run en el directorio donde guardaste el driver .
  8. Suige las instruciones... La instalación fallará, esto ocurre porque el driver de nouveau está corriendo y no permitirá al driver de nvidia instalarse, (no te preocupes por eso, en este punto el driver de nvidia pondrá al de nouveau en un archivo blacklist, para prevenir que se cargue en el próximo inicio del sistema)
  9. Reinicia tu sistema y repite los pasos 4-7, esta vez la instalación debería ir bien y el driver se instalará correctamente.
  10. Reinicia tu sistema de nuevo o escribe sudo lightdm start

    *Esto puede variar dependiendo si has instalado nuevas actualizaiones del kernel. En ese caso sugiero empezar desde el paso 2, sigue las instruciones hasta que un mensaje de error aparezca diciendo que la ruta a las cabeceras del kernel no pueden ser encontradas y que tienes que instalar el paquete que falta (en mi caso linux-headers-3.5.0-17-generic)

Any doubt just write me back
Cualquier duda... escríbeme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.