Possible Duplicate:
Desktop does not show when I installed nvidia drivers!

I had 12.04 installed and had no problems at all, having had it setup on my Compaq Presario CQ62 for about 2 weeks (I'm new to Ubuntu and I had a spare laptop to experiment with). Last night, I installed 12.10 through the update manager. Now, I'm not seeing the Unity GUI if I select Default or Ubuntu, at all, just the Eclipse launcher which I had created sitting on the desktop. Even hitting the Windows key to bring up Dash doesn't work. But, when I select GNOME during login, I'm able to access everything in the GUI, including the menu folders for games, internet, system settings, etc.

There was a couple error message saying that a system file wasn't loading properly but I forgot to write these down, and now these error messages aren't loading when I restart. Will I need to wipe clean and reinstall?

  • Are you using the proprietary nvidia driver? If so, there is a bug where you need to install the kernel sources and headers before switching to the proprietary driver.
    – rft183
    Commented Oct 19, 2012 at 13:55
  • Looks like the issue is that the AMD chip is not supported by fglrx - once I uninstalled that, I was able to get my Unity view back.
    – lolajl
    Commented Oct 19, 2012 at 15:11
  • @JorgeCastro I don't think so, because I had the very same problem with an ATI graphic card. Commented Oct 21, 2012 at 11:34

4 Answers 4


I had the same problem myself. In my case there was some problem with configuration files. To check if that is a issue for you too, create a new user or use guest account. GUI should display as intended.

To fix it for your account:

Navigate to your home folder, delete any .gnome, .compiz folder you can find there. After that go to .config folder and repeat procedure with gnome and compiz folder there. Do not worry, Ubuntu will replace them with default files. Log out.

I'm sorry that i cannot provide you with more precise answer. This one may look a little dirty but it works.

  • While this solution is terrible in many ways, removing the compiz folder fixed some major problems I had with compiz crashing after login
    – Thelema
    Commented Nov 13, 2012 at 23:12

I had the same issue and solved it.


I re-enabled bumblebee default repository and reinstalled it (see link). It fetched nvidia-current and installed it. So, I assume for those who do not have bumblebee that reinstalling nvidia-current will also solve the issue.

  • Actually this worked for me, but I had degraded performance. I searched a little more and found this: link and my resolution was better and so was performance!
    – itnet7
    Commented Oct 20, 2012 at 0:13

I solved this issue by uninstalling fglrx. My system uses a "Legacy" ATI Radeon card and the changes in xorg and opengl along with driver support made this necessary.

sudo apt-get autoremove fglrx --purge

  • I had exactly the same problem with an ATI Radeon HD 4500 card. The package fglrx was not installed on my system, but fglrx-updates and fglrx-amdcccle-updates. I removed those two packages and rebooted the system and everything was back in place. So +1 for your answer - I probably would never have figured it out otherwise! Commented Oct 21, 2012 at 11:30

I have the same problem. The login screen is ok.
I started a Gnome session and that was OK too.
Starting a Ubuntu session: only a desktop background, no panel or unity.
Via Ctrl+Alt+T I added a new user. Logging in as this new user; same problem.
Than I started the computer again with a 12.10 bootdisk.
It is busy for a few minutes now trying to find to screen setting; flickering screens and now and then only a background.

More to follow..

  • I installed another graphics card. It now works. Commented Oct 19, 2012 at 13:29

Not the answer you're looking for? Browse other questions tagged .