I just did a fresh install of Ubuntu 12.04 LTS and installed the nvidia drivers from their website (304.60 Latest Long Lived Branch).

They are just not working. Resolution is down to 640x540 or something. I run sudo nvidia-xconfig getting as result:

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as
New X configuration file written to '/etc/X11/xorg.conf'

but when I try to open the settings with nvdia-settings I get:

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Hence I restart the X server (sudo restart lightdm) but once again I get the same results.

Here is my xorg.conf file:

memecs@memecs-drz:~$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.60  (buildmeister@swio-display-x86-rhel47-04.nvidia.com)  Sun Oct 14 21:34:47 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Any help is really appreciated. Thanks!

  • Thanks, this is the exact problem I had (same laptop and graphics card) and disabling optimus worked. – Jason Axelson Dec 8 '12 at 0:57

Problem solved. Need to disable optimus from BIOS. Then everything works fine.

  • How did you disable it? Thanks. – user107276 Nov 11 '12 at 20:19
  • @Angelo press f2 when booting. Then under video disable Optimus – Jason Axelson Dec 8 '12 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.