I have a laptop with ATI Radeon 6770M HD Hybrid graphics card. In Ubuntu 12.04, I installed the fglrx driver through "additional drivers" and it worked. (I can even switch GPUs). But in the new Ubuntu 12.10, after installing, Unity won't load.

Only the mouse and the wallpaper. If I initialize the settings sudo aticonfig --initial then after rebooting it gives a warning saying I'm in low graphics mode! How to fix this?

Earlier I used software source to install the drivers. But when using the terminal, I got this warning :

update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken

Update : Filed a bug report in launchpad : https://bugs.launchpad.net/fglrx/+bug/1068661

  • Just filed a bug report : bugs.launchpad.net/fglrx/+bug/1068661
    – THpubs
    Oct 19, 2012 at 14:23
  • 2
    I believe this issue is because the ATI drivers do not yet support the current X Server 1.13. So we are going to be waiting on ATI. Oct 19, 2012 at 16:11
  • 1
    I've just added my comments to that bug report. I find it somewhat shocking that a bug like this made it through to final, as ATI cards are not that rare... Oct 21, 2012 at 11:16
  • 1
    AMD released a special 12.9 beta driver that would work with the xserver 1.13 in 12.10: support.amd.com/us/kbarticles/Pages/…; however, this doesn't seem to have been packaged into the default repository yet. Also, it only supports HD 5000 or later cards: askubuntu.com/questions/203232/…
    – Andrew Mao
    Oct 21, 2012 at 20:19
  • 1
    Guys, please add this information in either answers or add it to existing answers, information should be posted there, not buried in comments! Nov 10, 2012 at 13:50

8 Answers 8


I started with a clean 12.10 install (not an upgrade) My card is a Radeon HD 5450

First thing I done was to install Linux-source and Linux headers

sudo apt-get install linux-source
sudo apt-get install linux-headers-generic

I noticed that many with Nvidia cards were having to do this and am sure I saw mentioned some-where that it also helped ATI users.

Like everyone else if I installed either of the proprietary drivers after reboot I was able to login but lost unity.

One thing I did notice is that installing the driver did not install Catalyst control centre (not sure if it is the same for everyone else)

So I installed Synaptic package manager and installed fglrx-updates from there

enter image description here

Now the Catalyst control centre was installed.

Upon rebooting however instead of being able to login with no Unity the system was hanging at the splash screen.

So I applied nomodeset and this time it booted with Unity present

Here is the result of fglrxinfo

enter image description here

And here is what software sources says

enter image description here

With nomodeset applied I might not be getting the splash screen on boot up but fglrx-updates is working well. I would go as far as to say that it is performing better than it was in 12.04

More info

Grub offers me 2 kernels

3.5.0-18-generic and 3.5.0-17-generic

The later one '18' is good, the older one '17' still loads without Unity

  • 3
    On a just-installed Ubuntu 12.10 I installed linux-headers-generic, fgrlx-updates and fgrlx-amdcccle-updates then restarted and the driver (including Catalyst Control Center) have been installed. I didn't nomodeset, but unlike you, I didn't try to install the proprietary driver before.
    – Zippo
    Oct 24, 2012 at 12:26
  • @Zippoxer perhaps you could add this information to this bug report bugs.launchpad.net/fglrx/+bug/1068661 It may help others and help get the bug sorted quicker. Oct 24, 2012 at 18:50
  • 1
    Can't apply 'nomodeset' or it doesn't help. I've added nomodeset to boot by this instruction ubuntuforums.org/showthread.php?t=1613132 but still getting hanged splash screen. How to fix it?
    – megas
    Nov 29, 2012 at 15:02
  • This has worked for me on an HD5450. I previously tried so many other guides without success. I had linux-source and linux-headers-generic already installed so I didn't have to this time. I followed your instructions and everything is working perfectly. However, I didn't have to do apply monodeset. Thanks very much! Apr 6, 2013 at 13:13
  • @Jean-Louis nomodeset, not monodeset. Sadly, I've tried this advice but even with nomodeset my unity is gone and my terminal doesn't work. Messed up.
    – raindrop
    Aug 16, 2013 at 22:58

For those who have hybrid systems (ATI/intel) and fglrx has stopped working in 12.10, then the problem might be like the one described here (fglrx incompatibility with the recent version of the intel driver): https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1068404

What I would suggest would be

  1. Remove all the fglrx* packages:

    sudo apt-get purge fglrx*
  2. Add my PPA in your repositories list:

    sudo add-apt-repository ppa:andrikos

  3. Update your package information:

    sudo apt-get update 
  4. Update the fglrx and intel drivers:

    sudo apt-get install fglrx xserver-xorg-video-intel
  5. Don't forget to enable the fglrx driver

    sudo aticonfig --initial --force
  • Hi Nick, I tried your solution by unfortunately it didn't work out for me. Also i am wondering if the command under 4. should be sudo aticonfig --initial? I also could not find the command under the aticonfig man pages; see man.cx/aticonfig(1)
    – davorao
    Oct 28, 2012 at 14:09
  • Yes davorao, it is initial, I'm fixing it now. What system do you have? This solution is for the hybrid ATI/intel under ubuntu 12.10 Oct 29, 2012 at 15:37
  • Hi Nick, my system is a Intel HD3000 acting as the integrated GPU with a Radeon HD 6490M as the discrete GPU. The Laptop in question is the Samsung Chronos 7 700z3a-S03-DE. I have tried the using the xserver-xorg-video-intel deb from your PPA but couldn't manage to get it working.
    – davorao
    Nov 2, 2012 at 11:14
  • I tried this solution. It worked. But I have nasty "AMD testing only" box and (not sure if connected, but very probable) my mouse hangs sometimes and sometimes also with keyboards - especially when selecting something in unity bar. Do you think it's connected? More stable solution would be better!
    – greg606
    Nov 2, 2012 at 14:39
  • I would believe this is another bug. If my solution worked for you, could you please vote it up so that more people see it? Thanks Nov 3, 2012 at 15:51

I went to terminal (Ctrl+Alt+F1 for example) and did :

sudo apt-get remove fglrx

Now my computer is pretty slow but a least I can use it and wait for the problem to be fixed.


I found the problem. On upgrade of Ubuntu 12.04 -> Ubuntu 12.10, the contents of lightdm.conf in /etc/lightdm/ are completely erased. Installing or reconfiguring lightdm does NOT install this file here, so lightdm does not know how to go about displaying itself. You must do the following:

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop && sudo nano /etc/lightdm/lightdm.conf

insert the following text:


Save the file via CTRL + X and sudo reboot. You may not have to uninstall fglrx, but I do not know.

  • 1
    can you please tell us the steps you followed? Installed fglrx from the additional drivers and installed gdm?
    – THpubs
    Oct 19, 2012 at 7:51
  • sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop && revised contents above on how to configure lightdm.
    – mmstick
    Oct 19, 2012 at 7:58
  • one small problem... just recognized that you have updated from ubuntu 12.04. Im on a new installation
    – THpubs
    Oct 19, 2012 at 8:04

This works for me.

    sudo apt-get install linux-headers-generic

Go to amd.com and download their latest beta driver (which was just updated to 12.11). Run and install.

Please note that the stable driver will not work with unity.

Then head here to get a script to remove the watermark: http://areyoueye.net/?p=187


  • Hi @ryanpcmcquen do you have a pure AMD/ATI graphics card or do you have an Intel one working as the integrated besides the AMD/ATI discrete. I'm finding that for those with only AMD/ATI cards your solution with the new AMD Catalyst 12.11 drivers does work, but for those with an added Intel integrated card this doesn't provide the solution.
    – davorao
    Oct 25, 2012 at 6:02
  • I have the A8, so no Intel. Nov 7, 2012 at 18:47
  • 1
    This worked for me with the Radeon HD 5670. Dec 9, 2012 at 23:26
  • Using the beta driver was the only solution that actually worked on my system, also using a single Radeon HD card. Dec 25, 2012 at 23:18

There is an open bug at this time with fglrx-installer and Ubuntu 12.10


I always say "search for open and confirmed bugs" before you proceed with something, especially when the distribution is new released.

You can participate to this bug if affects you ,by posting comments there and click the button "Yes it affects me" (you have to have a Launchpad account).


Solution for me:

  1. remove current fglrx sudo sh /usr/share/ati/fglrx-uninstall.sh sudo apt-get remove --purge fglrx*

  2. add ppa repository sudo apt-add-repository ppa:andrikos/ppa

  3. update packages list sudo apt-get update

  4. install packages sudo apt-get install fglrx-updates


I got the same problem. May i found a possible solution. First i opened the Ubuntu-Software-Center and i was looking for "additional drivers". After installing the "additional drivers" i installed the ATI driver and after a reboot my notebook startet normally with unity and with the right propietary driver.

Note: The installation from the Software-Sources-button was not working in my case.

  • 1
    That would fit in with my solution, could there be something wrong with with the package offered in software sources? Oct 22, 2012 at 16:37
  • Didn't worked for me :(
    – THpubs
    Oct 23, 2012 at 16:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .