I upgraded from 12.04.1 to 12.10 via the Update Manager and the upgrade said it completed successfully, however after rebooting the Unity task bar was missing along with the launch bar and the window decorations.

All compiz settings seemed to be purge deleted, and at first boot it gave me a system error. The desktop exists, and once I remember I messed up the compiz settings and just had to press Ctrl+Alt+F1 and in the virtual terminal type unity --reset then sudo reboot.

Everything worked as if I reinstalled the entire operating system. This time it said:

Warning no variable set. setting to :0. The reset option is now dupricated.

What am I suppose to do now? I need this fixed as soon as possible because I need a couple of certainly installed programs and the data within them (long story short).

  • Same issue here, if you solve it let me know. and I'll do the same. I think it may be something to do with the gfx driver, are you using nvidia-current
    – RobertPitt
    Oct 19, 2012 at 1:19
  • Also try doming a sudo apt-get install -f as things are missing, this should fix those.
    – RobertPitt
    Oct 19, 2012 at 1:20
  • it did do something, but still doesn't work Oct 19, 2012 at 2:34
  • can you re-explain everything, but tell me which step to do first? Oct 19, 2012 at 2:34
  • See this ansert: askubuntu.com/questions/202752/…
    – RobertPitt
    Oct 20, 2012 at 23:08

7 Answers 7


I finally got Unity back at a normal resolution with compiz working as usual (apparently). It doesn't feel as snappier as before, but at least I can work with it.

This is what I did (hope it helps others):

  • Tried resetting xorg.conf file as @RobertPitt suggested (which, actually, did nothing for me).

  • Then tried what @Freedom suggested, but there was no entry inside the additional drivers tab.

  • Googled for a while and tried the steps outlined in this page and this page. After following the first web page steps nothing changed. As for the second page, I couldn’t get the ATI driver package to build.

  • Out of frustration, I got rid of fglrx with sudo apt-get autoremove fglrx --purge and rebooted sudo shutdown -r now.

After reboot, everything looked and seemed to work as usual. So weird.

By the way, I have a Radeon HD 3400 (RV620) card and there's still no entry for proprietary drivers in the additional drivers tab.

  • thank you so much, it appeared again. i really appreciate help, you are a great guy!!!! Oct 19, 2012 at 19:48
  • @NickyBailuc Here's why ('the chip is not supported') askubuntu.com/questions/201541/…
    – Bucic
    Oct 24, 2012 at 19:06
  • The reason for this: askubuntu.com/questions/204410/… Also I can confirm the solution given by Estanislau - removing fglrx (proprietary driver) fixed the problem for me. I really recommend reading the information given under the link I pasted in this comment.
    – Bucic
    Oct 26, 2012 at 19:36
  • Thanks for the info Bucic. If I understood correctly, it seems that we, older card owners (pre-5xxx), can only use the open source drivers because the newest catalyst drivers do not support those chips and the newest xorg (which comes with quantal) does not work with the 12.6 legacy drivers... So, the only workaround at the moment is to actually remove fglrx. Oct 27, 2012 at 9:10
  • After reading this post I went straight to point 4 (sudo apt-get autoremove fglrx --purge and sudo shutdown -r now) and fixed my problem straight away! I have voted up this answer.
    – Andrew
    Nov 26, 2012 at 9:09

So I have just had the exact same issue, these are the steps that I had taken to get everything working OK.

Firstly, I had a resolution warning so I cleared my xorg config using tty1 (Ctrl+Alt+F1), login and execute the following commands:

sudo su -
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back
echo "" > /etc/X11/xorg.conf
reboot -r now

Secondly, I ran the re-install packages command to update everything using:

sudo apt-get install -r

Lastly, once completed, reboot the machine using:

sudo reboot -r now

At this point everything started working again, I just have to redo my NVidia graphics settings.

  • I have AMD Radeon HD 4850, and after typing "sudo reboot -r now" it gave an error saying "invalid option" and after "sudo apt-get install -r" it said that the command is unknown. Can yo check over what you wrote, or is this because I have ASMD? Oct 19, 2012 at 2:07
  • Try just doing sudp apt-get install --reinstall and also just use sudo reboot`
    – RobertPitt
    Oct 20, 2012 at 23:07

I had the same issue, except I have an AMD Radeon HD 7750.

I tried following the answer above, but I had no luck.

What worked for me was changing to proprietary drivers. Here is what I did:

  1. Right click on the Desktop and select "Change Desktop Background".
  2. At the top click on "All Settings" (There might be a better way of getting into System Settings, but this is the only way I was able to do it without having Unity up).
  3. Scroll down and click on "Software Resources" and click on the "Additional Drivers" tab.
  4. Switch to "Using Video driver for the AMD graphics accelerators from fglrx(proprietary)" instead of "Using x.org xserver- AMD/ATI display driver wrapper from xserver-zorg-video-ati( Open Scource, tested)".
  5. Click on "Apply Changes"
  6. After that's done press Ctrl+Alt+Del to log-off and restart

After you reboot, Unity should be working fine. I don't know if this is a permanent fix or just a temporary fix.

I do want to point out that after I got it working I tried to re-install the Linux AMD driver I downloaded off the AMD site and it broke Unity again. I had to repeat this process to get it working again.

Thank you, hope this helps =)


Same here. removing fglrx as per https://help.ubuntu.com/community/BinaryDriverHowto/ATI noted above fixed the problem. Didn't need to reinstall fglrx


I had the same problem and tried several of the suggested steps above with little result. In the end I started trying to manually install a proprietary driver as instructed at https://help.ubuntu.com/community/BinaryDriverHowto/ATI

After performing step 2

sudo apt-get remove --purge fglrx-updates fglrx-amdcccle-updates

and then rebooting everything was back to normal, without even having to install a driver (although I guess I'm currently running without one as system info says unknown on graphics.)


I'm a Linux newbie and have no idea what I'm doing but here's how I fixed this problem. I booted to my previous kernel. Upon rebooting, at the screen where it asks for which operating system to boot to, I chose advanced options and it shows the kernels installed. I booted to the second kernel (just before the latest update) and everything booted fine. I then did

sudo apt-get update
sudo apt-get upgrade

Rebooted my system and let it boot normally and everything is fine once again.


Try to reset Unity by using this command. The EXACT THING happen with my unity And i reset it using this command. Yes it take some time to reset as there are many files to reset.

unity --reset

  • i already did that read the question Oct 20, 2012 at 15:28
  • doesn't work for 12.10. I get "ERROR: the reset option is now deprecated"
    – hafichuk
    Oct 22, 2012 at 2:45
  • Sorry to hear that, I was not aware that this is omitted in 12.10. Check out these threads askubuntu.com/questions/197535/cant-see-unity-bar-and-panel askubuntu.com/questions/17610/…
    – OmiPenguin
    Oct 22, 2012 at 6:37
  • it ok man, it works now, it was just my awesome Catalyst driver that was interfering with that piece of crap gallium driver, now i just need to figure out a way on how to remove it, and get Catalyst back Oct 27, 2012 at 1:22
  • Also doesn't work for 14.04. I get "ERROR: the reset option is now deprecated"
    – hakre
    Sep 25, 2018 at 16:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .