I have installed 12.04 on a dell vostro 2420 (previously 11.10) and wifi is gone now but wired network remains. I've reviewed the other questions and tried some stuff but no luck yet. The following is the process so far so hopefully someone can help:

After installing 12.04 using the additional drivers utility did not bring up any proprietary drivers and using synaptic on installation then reinstallation of bcmwl-kernel-source and b43-fwcutter does not help bring up any drivers either (tried rebooting after as well)

I have made sure in the bios that the wlan is turned on, and it appears the laptop does not have a wireless hardware switch, only the keyboard function shortcut which turns bluetooth on and off on the taskbar but there is no lightup of the wireless function on the laptop itself.

Dell does not appear to have any drivers for ubuntu and google does not appear to be much help :(

Thanks in advance!

  • Welcome to Ask Ubuntu! We need to double check your wireless hardware information to help you, can you look at this question and then edit your question adding the information. – fossfreedom Oct 18 '12 at 22:48
  • Please try 'sudo lspci' or 'sudo lshw' and verify the wifi card make and model. That would go a long way to help us help you. (I'm on my phone and don't have a 'back tic'. Would someone be so kind as to fix the code portion for me?) – Argusvision Oct 19 '12 at 0:46

I got it working, same model, on linux mint 13 64-bit, which is based off of ubuntu 12.04. Assuming your laptop came with the same hardware configuration:

Do a lspci -nn | grep Network, and if you get the following: 01:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4365] (rev 01) then my solution may work for you.

There's a related question on here, How do I install BCM43142 wireless drivers for Dell Vostro 3460/3560?. The steps described there may work for you. It didn't quite work for me, I didn't know what to do after installing the .deb package.

The following driver did work for me: http://jas.gemnetworks.com/wireless-bcm43142/

He has apt sources to make it easy to install (as found at the root of that site):

wget http://jas.gemnetworks.com/jasmineaura.gpg.key -O- | sudo apt-key add -

The sources are:

deb http://jas.gemnetworks.com/debian debian main  
deb-src http://jas.gemnetworks.com/debian debian main

Then, just:

sudo apt-get update  
sudo apt-get install wireless-bcm43142-dkms

The package also removes the conflicting packages from the old proprietary drivers that don't work, which I believe was what caused me problems when I tried to use the deb package in the question linked above.

  • Just write the URL in back-quotes ( ` ) and it will not register as hyperlink. – VedVals Dec 10 '12 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.